poj 2367 前向星+拓撲排序

Genealogical tree
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 4402   Accepted: 2922   Special Judge

Description

The system of Martians' blood relations is confusing enough. Actually, Martians bud when they want and where they want. They gather together in different groups, so that a Martian can have one parent as well as ten. Nobody will be surprised by a hundred of children. Martians have got used to this and their style of life seems to them natural.
And in the Planetary Council the confusing genealogical system leads to some embarrassment. There meet the worthiest of Martians, and therefore in order to offend nobody in all of the discussions it is used first to give the floor to the old Martians, than to the younger ones and only than to the most young childless assessors. However, the maintenance of this order really is not a trivial task. Not always Martian knows all of his parents (and there's nothing to tell about his grandparents!). But if by a mistake first speak a grandson and only than his young appearing great-grandfather, this is a real scandal.
Your task is to write a program, which would define once and for all, an order that would guarantee that every member of the Council takes the floor earlier than each of his descendants.

Input

The first line of the standard input contains an only number N, 1 <= N <= 100 — a number of members of the Martian Planetary Council. According to the centuries-old tradition members of the Council are enumerated with the natural numbers from 1 up to N. Further, there are exactly N lines, moreover, the I-th line contains a list of I-th member's children. The list of children is a sequence of serial numbers of children in a arbitrary order separated by spaces. The list of children may be empty. The list (even if it is empty) ends with 0.

Output

The standard output should contain in its only line a sequence of speakers' numbers, separated by spaces. If several sequences satisfy the conditions of the problem, you are to write to the standard output any of them. At least one such sequence always exists.

Sample Input

5
0
4 5 1 0
1 0
5 3 0
3 0

Sample Output

2 4 5 3 1

Source

Ural State University Internal Contest October'2000 Junior Session
解題思路:
顯然題目是想讓你輸出一個拓撲序,所以用有向圖來表示關係,再拓撲排序就好了;
這裏用到了前向星這種高效的數據結構來存儲圖;
info[i]表示從第i個點出發的第一條邊;
next[i]表示第i條邊的下一條邊;(沒有用-1表示)
to[i]表示第i條邊指向的點;
代碼:
#include<cstdio>
#include<cstring>
#include<vector>
using namespace std;
#define MAXN 105
int info[MAXN],vis[MAXN],queue[MAXN];
vector<int> next,to;
int front=0,rear=0,n;
void add(int i,int j)
{
	to.push_back(j);
	next.push_back(info[i]);
	info[i]=to.size()-1;
}
void init()
{
	memset(info,-1,sizeof(info));
	memset(vis,0,sizeof(vis));
	front=rear=0;
	to.clear();
	next.clear();
}
void toposort()
{
	for(int i=0;i<to.size();i++)
    vis[to[i]]++;
    for(int i=1;i<=n;i++)
    if(vis[i]==0)
    queue[rear++]=i;
    for(int i=1;i<=n;i++)
    {
    	if(front==rear)
    	break;
        int addr=info[queue[front++]];
        while(addr!=-1)
        {
            vis[to[addr]]--;
            if(vis[to[addr]]==0)
            queue[rear++]=to[addr];
            addr=next[addr];
        }
    }
}
int main()
{
	int a;
	while(scanf("%d",&n)!=EOF)
	{
		init();
		for(int i=1;i<=n;i++)
		{
			while(scanf("%d",&a)&&a)
			add(i,a);
		}
		toposort();
		for(int i=0;i<rear-1;i++)
   	 	printf("%d ",queue[i]);
		printf("%d\n",queue[rear-1]);
	}
	return 0;
}




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章