剪花布條

一塊花布條,裏面有些圖案,另有一塊直接可用的小飾條,裏面也有一些圖案。對於給定的花布條和小飾條,計算一下能從花布條中儘可能剪出幾塊小飾條來呢? 
Input輸入中含有一些數據,分別是成對出現的花布條和小飾條,其布條都是用可見ASCII字符表示的,可見的ASCII字符有多少個,布條的花紋也有多少種花樣。花紋條和小飾條不會超過1000個字符長。如果遇見#字符,則不再進行工作。 
Output輸出能從花紋布中剪出的最多小飾條個數,如果一塊都沒有,那就老老實實輸出0,每個結果之間應換行。 
Sample Input
abcde a3
aaaaaa  aa
#
Sample Output
0
3

KMP的簡單運用

    題意:判斷A字符串有多少個B

                         


#include <iostream>
#include <cstdio>
#include <cstring>
char str1[1000],str2[1000];
int next[1000];
int main()
{    
   while(~scanf("%s",str1))
   {
    if(str1[0] == '#')
       return 0;
    scanf("%s",str2);
    int l1 = strlen(str1);
    int l2 = strlen(str2);
    int i=0 , j = -1;
    next[0] = -1;
    while( i < l2)
    {
    	  if(j == -1 || str2[i] == str2[j])
    	  {
    	  	   i++;
    	  	   j++;
    	  	   next[i] = j;
		  }
		  else
		  {
		  	 j = next[j];
		  }
	}
//	for(int i = 0; i< l2; i++)
//	 printf("%d ",next[i]);
	int p = 0 , q = 0;
	int ans = 0;
	while(p < l1)
	{
		if( q == -1 || str1[p] == str2[q])
		  {
		  	   p++;
		  	   q++;
		  	   if(q == l2)
		  	      {
					ans++;
					q = 0;
				}
		  }
		else
		{
			  q = next[q];
		}
		
	}
	printf("%d\n",ans);
}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章