Matrix Chain Multiplication UVA - 442(矩陣連乘)

Suppose you have to evaluate an expression like ABCDE where A,B,C,D and E are matrices.
Since matrix multiplication is associative, the order in which multiplications are performed is arbitrary.
However, the number of elementary multiplications needed strongly depends on the evaluation order
you choose.
For example, let A be a 5010 matrix, B a 1020 matrix and C a 205 matrix. There are two
different strategies to compute A
BC, namely (AB)C and A(B*C).
The first one takes 15000 elementary multiplications, but the second one only 3500.
Your job is to write a program that determines the number of elementary multiplications needed
for a given evaluation strategy.
Input
Input consists of two parts: a list of matrices and a list of expressions.
The first line of the input file contains one integer n (1 ≤ n ≤ 26), representing the number of
matrices in the first part. The next n lines each contain one capital letter, specifying the name of the
matrix, and two integers, specifying the number of rows and columns of the matrix.
The second part of the input file strictly adheres to the following syntax (given in EBNF):
SecondPart = Line { Line }
Line = Expression
Expression = Matrix | “(” Expression Expression “)”
Matrix = “A” | “B” | “C” | … | “X” | “Y” | “Z”
Output
For each expression found in the second part of the input file, print one line containing the word ‘error’
if evaluation of the expression leads to an error due to non-matching matrices. Otherwise print one
line containing the number of elementary multiplications needed to evaluate the expression in the way
specified by the parentheses.
Sample Input
9
A 50 10
B 10 20
C 20 5
D 30 35
E 35 15
F 15 5
G 5 10
H 10 20
I 20 25
A
B
C
(AA)
(AB)
(AC)
(A(BC))
((AB)C)
(((((DE)F)G)H)I)
(D(E(F(G(HI)))))
((D(EF))((GH)I))
Sample Output
0
0
0
error
10000
error
3500
15000
40500
47500
15125

表達式解析

#include <cstdio>
#include <cstring>
#include <algorithm>
#include <vector>
#include <queue>
#include <stack>

using namespace std;

struct Node
{
    int x,y;
    int v;
}a[50];

char s[1005];

int main()
{
    int n;scanf("%d",&n);
    for(int i = 1;i <= n;i++)
    {
        char op[10];scanf("%s",op);
        int x,y;scanf("%d%d",&x,&y);
        a[op[0] - 'A'].x = x;
        a[op[0] - 'A'].y = y;
    }
    while(~scanf("%s",s + 1))
    {
        int len = (int)strlen(s + 1);
        stack<Node>stk;
        int ans = 0;
        int error = 0;
        for(int i = 1;i <= len;i++)
        {
            if(s[i] == '(')continue;
            else if(s[i] == ')')
            {
                Node y = stk.top();stk.pop();
                Node x = stk.top();stk.pop();
                Node z;
                if(x.y != y.x)
                {
                    error = 1;
                    break;
                }
                else
                {
                    z.x = x.x;z.y = y.y;
                    ans += x.x * x.y * y.y;
                    stk.push(z);
                }
            }
            else
            {
                int k = s[i] - 'A';
                stk.push(a[k]);
            }
        }
        if(error)printf("error\n");
        else printf("%d\n",ans);
    }
    
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章