hdu2602 01揹包Bone Collector

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)

Total Submission(s): 40316    Accepted Submission(s): 16748


Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?


 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
本人還沒有學c++尷尬


#include<stdio.h>
#include<string.h>
#include<algorithm>
using namespace std;
struct stu {
	int val;
	int cos;
}boy[10010];
//stu ;
//int bag[10010];
int nexty[10010];//如果把所有nexty都改爲next提交時出現編譯錯誤,應該是因爲next數組在c++裏面已經有定義(本人還沒有學c++)。
int main()
{
	int n;
	int a,b;
	scanf("%d",&n);
	while(n--)
	{
		scanf("%d%d",&a,&b);
		memset(boy,0,sizeof(boy));
	//	memset(bag,0,sizeof(bag));
		memset(nexty,0,sizeof(nexty));
		for(int i=0;i<a;i++)
		   scanf("%d",&boy[i].val);
		for(int j=0;j<a;j++)
		   scanf("%d",&boy[j].cos);
		for(int i=0;i<a;i++)
		{
			for(int j=b;j>=boy[i].cos;j--)
		//	bag[j]=max(bag[j],bag[j-boy[i].cos]+boy[i].val);
			nexty[j]=max(nexty[j],nexty[j-boy[i].cos]+boy[i].val);
		}
		//printf("%d\n",bag[b]);
		printf("%d\n",nexty[b]);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章