廣搜1—— Meteor Shower(流星雨)

Description
Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (Xi, Yi) (0 ≤ Xi ≤ 300; 0 ≤ Yi ≤ 300) at time Ti (0 ≤ Ti ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input
* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: Xi, Yi, and Ti

Output
* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output
5
題意:給你一個數字n,然後n行,每行有三個數(x, y, t)表示在t時刻流星雨落在(x, y)座標,並且把四個方向全炸燬,讓你求能逃到一個安全的地方用到的最短時間。
思路:先初始化,將(x, y)及其四個方向的點初始化成時間t,然後再搜索,從(0, 0)開始,能逃到的地方可以在300以外,這是一個坑。
初始化時候要的是時間小的。
給一下代碼:

#include <stdio.h>
#include <string.h>
#include <stdlib.h>
#include <queue>
#include <algorithm>
using namespace std;
int vis[400][400], vim[400][400];
int dis[4][2] = {1, 0, -1, 0, 0, 1, 0, -1};
struct xx
{
    int x, y;
}vv;
int check(int x, int y)
{
    if((x >= 0 && x <= 500) && (y >= 0 && y <= 500)) return 1;
    else return 0;
}
void bfs()
{
    int ans = 0, fl = 0;
    queue <xx> qq;
    vv.x = vv.y = 0;
    vim[0][0] = 0;
    qq.push(vv);
    while(!qq.empty())
    {
        vv = qq.front();
        qq.pop();
        int x1 = vv.x;
        int y1 = vv.y;
        if(vis[x1][y1] == -1)
        {
            ans = vim[x1][y1];
            fl = 2;
            printf("%d\n", ans);
            break;
        }
        for(int i = 0; i < 4; i++)
        {
            int x0 = x1 + dis[i][0];
            int y0 = y1 + dis[i][1];
            if(check(x0, y0) && !vim[x0][y0] && (vim[x1][y1] + 1 < vis[x0][y0] || vis[x0][y0] == -1))
            {
                vim[x0][y0] += vim[x1][y1] + 1;
                vv.x = x0;
                vv.y = y0;
                qq.push(vv);
            }
        }
    }
    if(!fl) puts("-1");
}
int main()
{
    int n, a, b, time;
    while(~scanf("%d", &n))
    {
        memset(vis, -1, sizeof(vis));
        memset(vim, 0, sizeof(vim));
        for(int i = 0; i < n; i++)
        {
            scanf("%d %d %d", &a, &b, &time);
            if(vis[a][b] == -1) vis[a][b] = time;
            else vis[a][b] = min(vis[a][b], time);
            for(int j = 0; j < 4; j++)
            {
                int x0 = a + dis[j][0];
                int y0 = b + dis[j][1];
                if(check(x0, y0))
                {
                    if(vis[x0][y0] == -1) vis[x0][y0] = time;
                    else vis[x0][y0] = min(vis[x0][y0], time);
                }
            }
        }
        bfs();
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章