PAT A1053. Path of Equal Weight (30)

  1. Path of Equal Weight (30)

時間限制
100 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue
Given a non-empty tree with root R, and with weight Wi assigned to each tree node Ti. The weight of a path from R to L is defined to be the sum of the weights of all the nodes along the path from R to any leaf node L.

Now given any weighted tree, you are supposed to find all the paths with their weights equal to a given number. For example, let’s consider the tree showed in Figure 1: for each node, the upper number is the node ID which is a two-digit number, and the lower number is the weight of that node. Suppose that the given number is 24, then there exists 4 different paths which have the same given weight: {10 5 2 7}, {10 4 10}, {10 3 3 6 2} and {10 3 3 6 2}, which correspond to the red edges in Figure 1.

Figure 1
Input Specification:

Each input file contains one test case. Each case starts with a line containing 0 < N <= 100, the number of nodes in a tree, M (< N), the number of non-leaf nodes, and 0 < S < 230, the given weight number. The next line contains N positive numbers where Wi (<1000) corresponds to the tree node Ti. Then M lines follow, each in the format:

ID K ID[1] ID[2] … ID[K]
where ID is a two-digit number representing a given non-leaf node, K is the number of its children, followed by a sequence of two-digit ID’s of its children. For the sake of simplicity, let us fix the root ID to be 00.

Output Specification:

For each test case, print all the paths with weight S in non-increasing order. Each path occupies a line with printed weights from the root to the leaf in order. All the numbers must be separated by a space with no extra space at the end of the line.

Note: sequence {A1, A2, …, An} is said to be greater than sequence {B1, B2, …, Bm} if there exists 1 <= k < min{n, m} such that Ai = Bi for i=1, … k, and Ak+1 > Bk+1.

Sample Input:
20 9 24
10 2 4 3 5 10 2 18 9 7 2 2 1 3 12 1 8 6 2 2
00 4 01 02 03 04
02 1 05
04 2 06 07
03 3 11 12 13
06 1 09
07 2 08 10
16 1 15
13 3 14 16 17
17 2 18 19
Sample Output:
10 5 2 7
10 4 10
10 3 3 6 2
10 3 3 6 2

#include<cstdio>
#include<vector>
#include<algorithm>
using namespace std;
const int maxn=105;

struct Node{
    int id;
    int weight;
    vector<Node>child;
}node[maxn];

int n,m,w;
vector<Node>path;
int pathw=0;

void DFS(int s){
    pathw+=node[s].weight;
    path.push_back(node[s]);
    if(node[s].child.size()==0){
        if(pathw==w){
            int i=path.size()-1;
            for(int j=0;j<=i;j++){
                printf("%d",path[j].weight);
                if(j<i)printf(" ");
                else printf("\n");
            }
        }
        path.pop_back();
        pathw-=node[s].weight;
        return;
    }
    for(int i=0;i<node[s].child.size();i++){
        DFS(node[s].child[i].id);
    }
    path.pop_back();
    pathw-=node[s].weight;
}

bool cmp(Node a,Node b){
    return a.weight>b.weight;
}
int main(){
    scanf("%d %d %d",&n,&m,&w);
    for(int i=0;i<n;i++){
        node[i].id=i;
        scanf("%d",&node[i].weight);
    }
    for(int i=0;i<m;i++){
        int idx,k;
        scanf("%d %d",&idx,&k);
        for(int j=0;j<k;j++){
            int s;
            scanf("%d",&s);
            node[idx].child.push_back(node[s]);
        }
        sort(node[idx].child.begin(),node[idx].child.end(),cmp);
    }
    DFS(0);
    return 0;
}

這裏寫圖片描述

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章