1015. Reversible Primes (20)

reversible prime in any number system is a prime whose "reverse" in that number system is also a prime. For example in the decimal system 73 is a reversible prime because its reverse 37 is also a prime.

Now given any two positive integers N (< 105) and D (1 < D <= 10), you are supposed to tell if N is a reversible prime with radix D.

Input Specification:

The input file consists of several test cases. Each case occupies a line which contains two integers N and D. The input is finished by a negative N.

Output Specification:

For each test case, print in one line "Yes" if N is a reversible prime with radix D, or "No" if not.

Sample Input:
73 10
23 2
23 10
-2
Sample Output:
Yes
Yes
No

#include <iostream>
#include <cstdio>
#include <cmath>
using namespace std;

bool isPrime(int n)
{
    if(n<=1) return false;
    int sqr=sqrt(1.0*n);
    for(int i=2;i<=sqr;i++)
    {
        if(n%i==0) return false;
    }
    return true;
}
int d[111];
int main()
{
    int n,radix;
    while(scanf("%d",&n)!=EOF)
    {
        if(n<0) break;
        scanf("%d",&radix);
        if(isPrime(n)==false)
        {
            printf("No\n");
        }
        else
        {
            int len=0,product=1;
            do
            {
               d[len++]=n%radix;
               n=n/radix;
            }while(n!=0);
            for(int i=0;i<len;i++)
            {
                n=n*radix+d[i];
            }
            if(isPrime(n)==true) printf("Yes\n");
            else printf("No\n");
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章