1105. Spiral Matrix (25)

This time your job is to fill a sequence of N positive integers into a spiral matrix in non-increasing order. A spiral matrix is filled in from the first element at the upper-left corner, then move in a clockwise spiral. The matrix has m rows and ncolumns, where m and n satisfy the following: m*n must be equal to N; m>=n; and m-n is the minimum of all the possible values.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N. Then the next line contains N positive integers to be filled into the spiral matrix. All the numbers are no more than 104. The numbers in a line are separated by spaces.

Output Specification:

For each test case, output the resulting matrix in m lines, each contains n numbers. There must be exactly 1 space between two adjacent numbers, and no extra space at the end of each line.

Sample Input:
12
37 76 20 98 76 42 53 95 60 81 58 93
Sample Output:
98 95 93
42 37 81
53 20 76
58 60 76
#include <iostream>
#include <vector>
#include <algorithm>
#include <cstdio>
#include <cmath>
using namespace std;

bool cmp(int a,int b)
{
    return a>b;
}

int main()
{
    int N;
    cin>>N;
    int num[N+10];
    int ans[N+10][N+10];
    for(int i=0;i<N;i++)
    {
        cin>>num[i];
    }
    if(N==1)
    {
        printf("%d",num[0]);
        return 0;
    }
    sort(num,num+N,cmp);
    int m=(int)ceil(sqrt(1.0*N));
    while(N%m!=0)
    {
        m++;
    }
    int n=N/m,i=1,j=1,now=0;
    int u=1,d=m,l=1,r=n;
    while(now<N)
    {
        while(now<N && j<r)
        {
            ans[i][j]=num[now++];
            j++;
        }
        while(now<N && i<d)
        {
            ans[i][j]=num[now++];
            i++;
        }
        while(now<N && j>l)
        {
            ans[i][j]=num[now++];
            j--;
        }
        while(now<N && i>u)
        {
            ans[i][j]=num[now++];
            i--;
        }
        u++,d--,l++,r--;
        i++,j++;
        if(now==N-1)
        {
            ans[i][j]=num[now++];
        }
    }
    for(int i=1;i<=m;i++)
    {
        for(int j=1;j<=n;j++)
        {
            printf("%d",ans[i][j]);
            if(j<n)
            {
                printf(" ");
            }
            else
            {
                printf("\n");
            }
        }
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章