1002. A+B for Polynomials (25) PAT甲級刷題

This time, you are supposed to find A+B where A and B are two polynomials.

Input

Each input file contains one test case. Each case occupies 2 lines, and each line contains the information of a polynomial: K N1 aN1 N2 aN2 ... NK aNK, where K is the number of nonzero terms in the polynomial, Ni and aNi (i=1, 2, ..., K) are the exponents and coefficients, respectively. It is given that 1 <= K <= 10,0 <= NK < ... < N2 < N1 <=1000.

Output

For each test case you should output the sum of A and B in one line, with the same format as the input. Notice that there must be NO extra space at the end of each line. Please be accurate to 1 decimal place.

Sample Input
2 1 2.4 0 3.2
2 2 1.5 1 0.5
Sample Output

3 2 1.5 1 2.9 0 3.2

思路:指數作數組下標來索引,保存係數,輸出數組中不爲0的數,注意都爲0的情況

#include <iostream>
#include <fstream>
#include <iomanip>
using namespace std;

int main()
{
    int n,exp;
    cin>>n;
    double coe,poly[1001]={0};
    for(int i=0;i<n;++i){
        cin>>exp>>coe;
        poly[exp] += coe;
    }
    cin>>n;
    for(int i=0;i<n;++i){
        cin>>exp>>coe;
        poly[exp] += coe;
    }
    int cnt=0;
    for(int i=0;i<1001;++i){
        if(poly[i]!=0)
            ++cnt;
    }
    cout<<cnt;
    for(int i=1000;i>=0;--i){
        if(poly[i]!=0)
          cout<<' '<<i<<' '<<fixed<<setprecision(1)<<poly[i];
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章