1046. Shortest Distance (20)

The task is really simple: given N exits on a highway which forms a simple cycle, you are supposed to tell the shortest distance between any pair of exits.

Input Specification:

Each input file contains one test case. For each case, the first line contains an integer N (in [3, 105]), followed by N integer distances D1 D2 ... DN, where Di is the distance between the i-th and the (i+1)-st exits, and DN is between the N-th and the 1st exits. All the numbers in a line are separated by a space. The second line gives a positive integer M (<=104), with M lines follow, each contains a pair of exit numbers, provided that the exits are numbered from 1 to N. It is guaranteed that the total round trip distance is no more than 107.

Output Specification:

For each test case, print your results in M lines, each contains the shortest distance between the corresponding given pair of exits.

Sample Input:
5 1 2 4 14 9
3
1 3
2 5
4 1
Sample Output:
3
10

7

#include <cstdio>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
    int n,m,sum=0;
    scanf("%d",&n);
    vector<int> p(n+1);
    vector<int> toNum1(n+1);
    for(int i=1;i<=n;i++)
    {
       scanf("%d",&p[i]);
       sum=sum+p[i];
       toNum1[i]=sum;
    }
    scanf("%d",&m);
    for(int i=0;i<m;i++)
    {
        int a,b;
        scanf("%d %d",&a,&b);
        if(a>b)
        {
            swap(a,b);
        }
        if(toNum1[b-1]-toNum1[a-1]<sum-toNum1[b-1]+toNum1[a-1])
        {
            printf("%d\n",toNum1[b-1]-toNum1[a-1]);
        }
        else
        {
            printf("%d\n",sum-toNum1[b-1]+toNum1[a-1]);
        }
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章