Relocation(POJ-2923)(狀壓DP+01揹包)

Emma and Eric are moving to their new house they bought after returning from their honeymoon. Fortunately, they have a few friends helping them relocate. To move the furniture, they only have two compact cars, which complicates everything a bit. Since the furniture does not fit into the cars, Eric wants to put them on top of the cars. However, both cars only support a certain weight on their roof, so they will have to do several trips to transport everything. The schedule for the move is planed like this:

  1. At their old place, they will put furniture on both cars.
  2. Then, they will drive to their new place with the two cars and carry the furniture upstairs.
  3. Finally, everybody will return to their old place and the process continues until everything is moved to the new place.

Note, that the group is always staying together so that they can have more fun and nobody feels lonely. Since the distance between the houses is quite large, Eric wants to make as few trips as possible.

Given the weights wi of each individual piece of furniture and the capacities C1 and C2 of the two cars, how many trips to the new house does the party have to make to move all the furniture? If a car has capacity C, the sum of the weights of all the furniture it loads for one trip can be at most C.

Input

The first line contains the number of scenarios. Each scenario consists of one line containing three numbers nC1 and C2. C1 and C2 are the capacities of the cars (1 ≤ Ci ≤ 100) and n is the number of pieces of furniture (1 ≤ n ≤ 10). The following line will contain n integers w1, …, wn, the weights of the furniture (1 ≤ wi ≤ 100). It is guaranteed that each piece of furniture can be loaded by at least one of the two cars.

Output

The output for every scenario begins with a line containing “Scenario #i:”, where i is the number of the scenario starting at 1. Then print a single line with the number of trips to the new house they have to make to move all the furniture. Terminate each scenario with a blank line.

Sample Input

2
6 12 13
3 9 13 3 10 11
7 1 100
1 2 33 50 50 67 98

Sample Output

Scenario #1:
2

Scenario #2:
3

題意:一對夫婦要搬新家,然後他們現在有兩輛車和n個物品,每個物品有固定的體積,兩輛車也有固定的容積,問你要把物品全部運走最少需要多少次。每次每輛車運送的物體總體積不得大於車的容積。

思路:這道題的話,需要用揹包和狀壓DP的算法去做。首先,我們先枚舉選擇若干個時的狀態, 總狀態量的話爲爲1<<n。然後我們判斷這些狀態集合裏的那些物品能否一次被運走,如果能運走,那就把這個狀態看成一個物品。然後我們枚舉了cnt個物品,再在這cnt個物品中沒有交集的物品進行01揹包,沒有交集的物品的意思就是兩個狀態不能含有同一個物品。每個物品的體積是state[i],價值是1,求n個物品的最小价值就是dp[(1<<n)-1]。(借鑑了dalao的思路)

AC代碼:

#include <stdio.h>
#include <string>
#include <string.h>
#include <algorithm>
#include <iostream>
#include <math.h>
typedef long long ll;
const int maxx=1030;
const int maxn=1<<10;
const int inf=0x3f3f3f3f;
using namespace std;
int state[maxx];
int dp[maxx];
bool vis[1010];
int a[maxx];
int n,c1,c2,cnt;
bool judge(int x)
{
    int sum=0;
    memset(vis,0,sizeof(vis));
    vis[0]=1;
    for(int i=0; i<n; i++)
    {
        if((x>>i)&1)
        {
            sum+=a[i];
            for(int j=c1; j>=a[i]; j--)
            {
                if(vis[j-a[i]])
                    vis[j]=1;
            }
        }
    }
    if(sum>c1+c2)
        return 0;
    for(int i=0; i<=c1; i++)
    {
        if(vis[i] && sum-i<=c2)
            return 1;
    }
    return 0;
}
int main()
{
    int t;
    scanf("%d",&t);
    int k=1;
    while(t--)
    {
        scanf("%d%d%d",&n,&c1,&c2);
        for(int i=0; i<n; i++)
            scanf("%d",&a[i]);
        cnt=0;
        for(int i=1; i<(1<<n); i++)
        {
            dp[i]=maxn;
            if(judge(i))
                state[cnt++]=i;
        }
        dp[0]=0;
        for(int i=0; i<cnt; i++)
        {
            for(int j=(1<<n)-1; j>=0; j--)
            {
                if(dp[j]==maxn)
                    continue;
                if((j&state[i])==0)
                {
                    dp[j|state[i]]=min(dp[j|state[i]],dp[j]+1);
                }

            }
        }
        printf("Scenario #%d:\n%d\n\n",k++,dp[(1<<n)-1]);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章