DNA Sequence POJ - 2778 ac自動機+矩陣快速冪

一、內容

It's well known that DNA Sequence is a sequence only contains A, C, T and G, and it's very useful to analyze a segment of DNA Sequence,For example, if a animal's DNA sequence contains segment ATC then it may mean that the animal may have a genetic disease. Until now scientists have found several those segments, the problem is how many kinds of DNA sequences of a species don't contain those segments.

Suppose that DNA sequences of a species is a sequence that consist of A, C, T and G,and the length of sequences is a given integer n.

Input

First line contains two integer m (0 <= m <= 10), n (1 <= n <=2000000000). Here, m is the number of genetic disease segment, and n is the length of sequences.

Next m lines each line contain a DNA genetic disease segment, and length of these segments is not larger than 10.

Output

An integer, the number of DNA sequences, mod 100000. 

Sample Input

4 3
AT
AC
AG
AA

Sample Output

36

二、思路

在這裏插入圖片描述在這裏插入圖片描述

三、代碼

#include <cstdio>
#include <cstring>
#include <queue>
using namespace std;
const int N = 205, MOD = 1e5;
int n, m, len, tr[N][4], ne[N], fail[N];
char s[N]; 
struct Martrix {
	long long a[N][N];
	Martrix() { 
		for (int i = 0; i <= len; i++) {
			for (int j = 0; j <= len; j++) a[i][j] = 0;
		}
	}//初始化
};
int getId(char c) {
	if (c == 'A') return 0;
	if (c == 'T') return 1;
	if (c == 'G') return 2; return 3;
} 
void add() {
	int p = 0;
	for (int i = 0; s[i]; i++) {
		int j = getId(s[i]);
		if (!tr[p][j]) tr[p][j] = ++len;
		p = tr[p][j];
	}
	fail[p] = 1; //危險節點 
}
void build() {
	queue<int> q;
	for (int i = 0; i < 4; i++) {
		if (tr[0][i]) q.push(tr[0][i]);
	}
	while (!q.empty()) {
		int p = q.front(); q.pop();
		for (int j = 0; j < 4; j++) {
			int c = tr[p][j];
			if (!c) tr[p][j] = tr[ne[p]][j];
			else {
				ne[c] = tr[ne[p]][j];
				fail[c] |= fail[ne[c]]; //若後綴是病毒也要算上 
				q.push(c);
			}
		}
	} 
}
Martrix mul(Martrix &A, Martrix &B) {
	Martrix C;
	for (int i = 0; i <= len; i++) {
		for (int j = 0; j <= len; j++) {
			C.a[i][j] = 0;
			for (int k = 0; k <= len; k++) {
				C.a[i][j] += (A.a[i][k] * B.a[k][j]);
			}
			C.a[i][j] %= MOD; //MOD不大取餘一次即可 
		}
	}
	return C;
} 
void solve() {
	//通過trie數 構建A
	Martrix A, ans; 
	for (int p = 0; p <= len; p++) {
		for (int j = 0; j < 4; j++) {
			int c = tr[p][j];
			if (!fail[c] && !fail[p]) A.a[p][c]++; //代表有邊可走 
		}
	}
	//通過A 求出A^M
	for (int i = 0; i <= len; i++) ans.a[i][i] = 1;
	while (m) {
		if (m & 1) {
			ans = mul(ans, A);
		}
		A = mul(A, A);
		m >>= 1;
	} 
	
	long long sum = 0;
	for (int i = 0; i <= len; i++) sum = (sum + ans.a[0][i]) % MOD;
	printf("%lld", sum);
}
int main() {
	scanf("%d%d", &n, &m);	
	for (int i = 1; i <= n; i++) {
		scanf("%s", s); add();
	}
	build(); 
	solve();
	return 0;
} 
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章