【ZOJ】1048.Financial Management(Java 题解)

一、题目

原题链接:https://zoj.pintia.cn/problem-sets/91827364500/problems/91827364547

Larry graduated this year and finally has a job. He's making a lot of money, but somehow never seems to have enough. Larry has decided that he needs to grab hold of his financial portfolio and solve his financing problems. The first step is to figure out what's been going on with his money. Larry has his bank account statements and wants to see how much money he has. Help Larry by writing a program to take his closing balance from each of the past twelve months and calculate his average account balance.


Input Format:

The input will be twelve lines. Each line will contain the closing balance of his bank account for a particular month. Each number will be positive and displayed to the penny. No dollar sign will be included.


Output Format:

The output will be a single number, the average (mean) of the closing balances for the twelve months. It will be rounded to the nearest penny, preceded immediately by a dollar sign, and followed by the end-of-line. There will be no other spaces or characters in the output.


Sample Input:

100.00
489.12
12454.12
1234.10
823.05
109.20
5.27
1542.25
839.18
83.99
1295.01
1.75


Sample Output:

$1581.42

二、AC代码

啥也不说,快乐的水几题。

import java.util.Scanner;

public class P1048_AC_Financial_Management {
	public static void main(String[] args) {
		Scanner s = new Scanner(System.in);
		double sum = 0;
		for (int i = 0; i < 12; i++) {
			double line = s.nextDouble();
			sum+=line;
		}
		System.out.printf("%s%.2f", "$", sum/12.0);
	}
}	
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章