POJ-3617--最小字典序(貪心)

Best Cow Line

Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 48233 Accepted: 12237
Description

FJ is about to take his N (1 ≤ N ≤ 2,000) cows to the annual"Farmer of the Year" competition. In this contest every farmer arranges his cows in a line and herds them past the judges.

The contest organizers adopted a new registration scheme this year: simply register the initial letter of every cow in the order they will appear (i.e., If FJ takes Bessie, Sylvia, and Dora in that order he just registers BSD). After the registration phase ends, every group is judged in increasing lexicographic order according to the string of the initials of the cows’ names.

FJ is very busy this year and has to hurry back to his farm, so he wants to be judged as early as possible. He decides to rearrange his cows, who have already lined up, before registering them.

FJ marks a location for a new line of the competing cows. He then proceeds to marshal the cows from the old line to the new one by repeatedly sending either the first or last cow in the (remainder of the) original line to the end of the new line. When he’s finished, FJ takes his cows for registration in this new order.

Given the initial order of his cows, determine the least lexicographic string of initials he can make this way.

Input

  • Line 1: A single integer: N
  • Lines 2…N+1: Line i+1 contains a single initial (‘A’…‘Z’) of the cow in the ith position in the original line

Output

The least lexicographic string he can make. Every line (except perhaps the last one) contains the initials of 80 cows (‘A’…‘Z’) in the new line.

Sample Input

6
A
C
D
B
C
B

Sample Output
ABCBCD

Source

USACO 2007 November Silver

AC代碼

#include <algorithm>
#include <iostream>
#include <cstring>
#include <string>
using namespace std;

int main() {
	int n;
	char ch;
	string str = "";
	string ans = "";
	cin >> n;
	for (int i = 0; i < n; i++) {
		cin >> ch;
		str += ch;
	}
	string re_str = str;
	reverse(re_str.begin(), re_str.end());//拷貝並翻轉字符串
	//每次取出一個字符
	while (ans.length() < n) {
		if (str < re_str) {
			ans += str.at(0);
			str = str.substr(1);
		}
		else {
			ans += re_str.at(0);
			re_str = re_str.substr(1);
		}
	}
	int line = 0;
	//每80個字符換行
	while (line < ans.length() / 80) {
		cout << ans.substr(line * 80, 80) << endl;
		line++;
	}
	cout << ans.substr(line * 80) << endl;
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章