【HDU 3555】 Bomb 數位dp

Problem Description
The counter-terrorists found a time bomb in the dust. But this time the terrorists improve on the time bomb. The number sequence of the time bomb counts from 1 to N. If the current number sequence includes the sub-sequence “49”, the power of the blast would add one point.
Now the counter-terrorist knows the number N. They want to know the final points of the power. Can you help them?

Input
The first line of input consists of an integer T (1 <= T <= 10000), indicating the number of test cases. For each test case, there will be an integer N (1 <= N <= 2^63-1) as the description.

The input terminates by end of file marker.

Output
For each test case, output an integer indicating the final points of the power.

Sample Input
3
1
50
500

Sample Output
0
1
15

Hint
From 1 to 500, the numbers that include the sub-sequence “49” are “49”,“149”,“249”,“349”,“449”,“490”,“491”,“492”,“493”,“494”,“495”,“496”,“497”,“498”,“499”,
so the answer is 15.

題意:找到【1,N】內數位裏包含“49”子串的數的個數

思路(數位dp):

典型的數位dp題,我用dp[pos][sta][flag]來記錄pos位置下,前面有無4(sta),以及之前有沒有湊到過“49”(flag),然後枚舉每個數位的各個數字即可,如果sta爲真,就要對當前的‘9’分類討論,遇到‘9’就flag置爲真,然後往下繼續搜索,到底了就看看flag是否爲真,判斷有沒有湊到49.

AC代碼:

#include <iostream>
#include <cstdio>
#include <cstring>
#include <string>
#include <vector>
#include <map>
#include <cmath>
#include <algorithm>
using namespace std;
typedef long long ll;
ll dp[100][2][2];
ll a[100];

ll dfs(ll pos, bool sta, bool flag, bool limit )
{
    if(pos==-1)  return flag;
    if(!limit&&dp[pos][sta][flag]!=-1) return dp[pos][sta][flag];
    ll up = limit?a[pos]:9;
    ll ans = 0;
    for(ll i=0;i<=up;i++)
    {
          if(sta&&i==9) ans += dfs(pos-1,i==4, true, limit&&i==a[pos]);
          else  ans += dfs(pos-1,i==4,flag, limit&&i==a[pos]);
    }
    if(!limit) dp[pos][sta][flag] = ans;
    return ans;
}

ll solve(ll x)
{
    ll pos = 0;
    while(x)
    {
        a[pos++] = x%10;
        x /= 10;
    }
    return dfs(pos-1,false, false, true);
}

int main()
{
    memset(dp,-1,sizeof(dp));
    int kase;
    cin>>kase;
    while(kase--)
    {
        ll x;
        cin>>x;
        cout<<solve(x)<<endl;
    }
    return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章