【C++】Sliding Window

【来源】

POJ-2823
vjudge

【题目描述】

An array of size n ≤ 106 is given to you. There is a sliding window of size k which is moving from the very left of the array to the very right. You can only see the k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example:
The array is [1 3 -1 -3 5 3 6 7], and k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position.

【输入格式】

The input consists of two lines. The first line contains two integers n and k which are the lengths of the array and the sliding window. There are n integers in the second line.

【输出格式】

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values.

【样例输入】

8 3
1 3 -1 -3 5 3 6 7

【样例输出】

-1 -3 -3 -3 3 3
3 3 5 5 6 7

【题目大意】

给您一个大小为n的数组。有一个k大小的滑动窗口,它从数组的最左边移动到最右边。您只能在窗口中看到K数字。每次滑动窗口向右移动一个位置。给定一个序列,对于所有的i>=k,输出序列中[i-k+1,i]内的最大值和最小值。

【解析】

单调队列优化动态规划模板题。
分别求min和max即可。

【代码】

本代码用C++提交。
若用G++提交请将O3优化去掉,并使用快读。

#pragma GCC optimize(3,"Ofast","inline")
#pragma G++ optimize(3,"Ofast","inline")

#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>

#define RI                 register int
#define re(i,a,b)          for(RI i=a; i<=b; i++)
#define ms(i,a)            memset(a,i,sizeof(a))
#define MAX(a,b)           (((a)>(b)) ? (a):(b))
#define MIN(a,b)           (((a)<(b)) ? (a):(b))

using namespace std;

typedef long long LL;

const int N=1e6+5;
const int inf=1e9;

int n,k;
int a[N],q[N];

inline void calcmin() {
	int l=1,r=0;
	for(int i=1; i<=n; i++) {
		while(l<=r && a[i]<a[q[r]]) r--;
		q[++r]=i;
		while(l<=r && i-q[l]>=k) l++;
		if(i>=k) printf("%d ",a[q[l]]);
	}
	printf("\n");
}

inline void calcmax() {
	int l=1,r=0;
	for(int i=1; i<=n; i++) {
		while(l<=r && a[i]>a[q[r]]) r--;
		q[++r]=i;
		while(l<=r && i-q[l]>=k) l++;
		if(i>=k) printf("%d ",a[q[l]]);
	}
	printf("\n");
}

int main() {
	scanf("%d%d",&n,&k);
	for(int i=1; i<=n; i++) scanf("%d",&a[i]);
	calcmin();
	calcmax();
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章