(PAT)1152 Google Recruitment (20分) (cj)

声明: 博客内所有英文题目来自 https://pintia.cn/  中 PAT(Advanced Level) Practice, 博客内容只用于学术目的,仅为PAT入门提供一个参考,不用于任何商业行为。

                                                                  1152 Google Recruitment (20分)

In July 2004, Google posted on a giant billboard along Highway 101 in Silicon Valley (shown in the picture below) for recruitment. The content is super-simple, a URL consisting of the first 10-digit prime found in consecutive digits of the natural constant e. The person who could find this prime number could go to the next step in Google's hiring process by visiting this website.

prime.jpg

The natural constant e is a well known transcendental number(超越数). The first several digits are: e = 2.718281828459045235360287471352662497757247093699959574966967627724076630353547594571382178525166427427466391932003059921... where the 10 digits in bold are the answer to Google's question.

Now you are asked to solve a more general problem: find the first K-digit prime in consecutive digits of any given L-digit number.

Input Specification:

Each input file contains one test case. Each case first gives in a line two positive integers: L (≤ 1,000) and K (< 10), which are the numbers of digits of the given number and the prime to be found, respectively. Then the L-digit number N is given in the next line.

Output Specification:

For each test case, print in a line the first K-digit prime in consecutive digits of N. If such a number does not exist, output 404 instead. Note: the leading zeroes must also be counted as part of the K digits. For example, to find the 4-digit prime in 200236, 0023 is a solution. However the first digit 2 must not be treated as a solution 0002 since the leading zeroes are not in the original number.

Sample Input 1:

20 5
23654987725541023819

Sample Output 1:

49877

Sample Input 2:

10 3
2468024680

Sample Output 2:

404

思路:在字符串中循环读取k个字符,然后将这k个字符转换为整数(long long 型)然后判断这个整数是不是素数就好了。

Code:

#include <iostream>
#include <algorithm>
#include <vector>
#include <map>
#include <stack>
#include <set>
#include <cmath>
#define abs(x) (x>0?x:-x)
#define edge 0x7fffffff
using namespace std;

bool isprime(long long x){
    if(x == 1 || x==2 )return 1;
    int len = sqrt(x);
    for(int i=2;i<=len+1;++i){
        if(x%i==0) return 0;
    }
    return 1;
}
int main(){
    char digits[1005]={0};
    char prime[12]={0};
    int l,k;
    bool f =1;
    scanf("%d %d",&l,&k);
    scanf("%s",digits);
    for(int i=0;i<=l-k;++i){
        for(int j=0;j<k;++j){
            prime[j]=digits[i+j];
        }
        long long x = atoll(prime);
        if(isprime(x)){
            printf("%s\n",prime);
            f=0;
            break;
        }
    }
    if(f) printf("404\n");
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章