UVA-11827 Maximum GCD(輾轉相除法求GCD)

Given the N integers, you have to find the maximum GCD (greatest common divisor) of every possible pair of these integers.

Input

The first line of input is an integer N (1 < N < 100) that determines the number of test cases.

The following N lines are the N test cases. Each test case contains M (1 < M < 100) positive integers that you have to find the maximum of GCD.

Output

For each test case show the maximum GCD of every possible pair.

Sample Input

3

10 20 30 40

7 5 12

125 15 25

Sample Output

20

1

25

題目意思是給你若干個數字(數字個數不確定),要求你求出任意兩個數的最大公約數的最大值。 

對於數字的分解可以有兩種方法:

        1:對於每組數據,通過循環,將一個個數字分解出來,並存入數組

        2:將每組數據以字符串形式放入字符串流中並通過istringstream將字符串類型轉化爲int類型

對於最大公因數的求解 由於數據量不大,直接暴力循環判斷即可

法一:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<cmath>

using namespace std;

int arr[1000];

int GCD(int a, int b) {
    if(a < b) {
        a = a + b;
        b = a - b;
        a = a - b;
    }
    int c = a % b;
    while(c) {
        a = b;
        b = c;
        c = a % b;
    }
    return b;
}

int main() {
    int n,res,m,Len,tmp;
    char str[10000];
    scanf("%d",&n);
    getchar();
    while(n--){
        m = 0;
        gets(str);
        Len = strlen(str);
        tmp = 0;
        for(int i = 0;i < Len;i++) {
            tmp = 0;
            while(str[i] != ' ' && str[i] != '\0') {
                tmp = tmp * 10 + str[i++] - '0';
            }
            arr[m++] = tmp;
        }
        res = 0;
        for(int i = 0;i < m;i++)
            for(int j = i + 1;j < m;j++)
                res = max(res,GCD(arr[i],arr[j]));
        printf("%d\n",res);
    }
    return 0;
}

法二:

#include<iostream>
#include<cstring>
#include<stdio.h>
#include<sstream>
#include<string>

using namespace std;

int arr[1000];

int GCD(int a, int b) {
    if(a < b) {
        a = a + b;
        b = a - b;
        a = a - b;
    }
    int c = a % b;
    while(c) {
        a = b;
        b = c;
        c = a % b;
    }
    return b;
}

int main() {
    int n,res,m,Len,tmp;
    char str[10000];
    scanf("%d",&n);
    getchar();
    while(n--){
        m = 0;
        gets(str);              //讀入一行
        istringstream istr(str);//把str中的字符串存入字符串流中
        int tmp;
        while(istr >> tmp) {    //以空格爲界,把istringstream中的數據取出,並將其轉化爲int類型
            arr[m++] = tmp;
        }
        res = 0;
        for(int i = 0;i < m;i++)
            for(int j = i + 1;j < m;j++)
                res = max(res,GCD(arr[i],arr[j]));
        printf("%d\n",res);
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章