HDU1025——Constructing Roads In JGShining's Kingdom

Constructing Roads In JGShining's Kingdom


Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 23075    Accepted Submission(s): 6582


Problem Description
JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines.

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource.

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one.

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II.

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones.

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads.

For example, the roads in Figure I are forbidden.



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^

 

Input
Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file.
 

Output
For each test case, output the result in the form of sample.
You should tell JGShining what's the maximal number of road(s) can be built.

 

Sample Input
2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output
Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.
題意:
一邊富城一邊窮城,一個富城只能鏈接一個窮城,問連線不交叉的情況下最多連幾條。
解題思路:
把任意一邊從小到大排序,連線的另一邊跟着排,排完後就是求最長上升子序列滴。
求LIS有兩種方法,一個時間複雜度爲o(n2),一個爲o(nlogn),由於本題數據有點大,採用第二種方法,不過這裏我把兩種方法都寫一下。
第一種:
#include<stdio.h>
#defineSIZE100  
/*
@parama表述基礎序列數組
@paramd[i]表示在a[i]爲最長子序列的尾部的位置
*/
 
intLIS(int*a,int*d)
{
 
    intmax=0;
    d[0]=1;

    for(inti=1;i<SIZE;i++)
    {
        d[i]=1;
        for(intj=0;j<i;j++)
        {  
            if(a[i]>a[j]&&d[i]+1>d[j])
            { 
                d[i]=d[j]+1;
            }
        }
        max=d[i]>max?d[i]:max;
    }
    returnmax;
}

上面這種方法複雜都有點高,不採用
接下來看第二種:
二分查找
#include<stdio.h>
#define SIZE 100000
int F[SIZE],n;
/*
b:棧中元素
s:待查找元素
length:棧中元素個數
*/
int dichotomy_search(int *b,int s,int length)
{
    int low=0,between=0;
    while(low<length)
    {
        between=(low+length)/2;
        if(b[between]>s)
            length=between-1;
        else
            low=between+1;
    }
    return low;
}
 
 
int LIS(int *a)
{
    int stack[SIZE],j=0;
    stack[j]=a[0];
    for(int i=1;i<n;i++)
    {
        if(a[i]>stack[i-1])
        {
            stack[j++]=a[i];
        }
        else if(a[i]<stack[i-1])
        {
            int n=dichotomy_search(stack,a[i],j+1);
            stack[n]=a[i];
        }
    }
    return j;
}

如果不理解看這個列子:

假設要尋找最長上升子序列的序列是a[n],然後尋找到的遞增子序列放入到數組b中。

(1)當遍歷到數組a的第一個元素的時候,就將這個元素放入到b數組中,以後遍歷到的元素都和已經放入到b數組中的元素進行比較;

(2)如果比b數組中的每個元素都大,則將該元素插入到b數組的最後一個元素,並且b數組的長度要加1;

(3)如果比b數組中最後一個元素小,就要運用二分法進行查找,查找出第一個比該元素大的最小的元素,然後將其替換。

在這個過程中,只重複執行這兩步就可以了,最後b數組的長度就是最長的上升子序列長度。例如:如該數列爲:

5 9 4 1 3 7 6 7

那麼:

5 //加入
5 9 //加入
4 9 //用4代替了5
1 9 //用1代替4
1 3 //用3代替9
1 3 7 //加入
1 3 6 //用6代替7
1 3 6 7 //加入

最後b中元素的個數就是最長遞增子序列的大小,即4。

要注意的是最後數組裏的元素並不就一定是所求的序列,

例如如果輸入 2 5 1

那麼最後得到的數組應該是 1 5

而實際上要求的序列是 2 5


<span style="font-size:18px;">最後題解</span>
<span style="font-size:18px;">代碼實現:</span>
<span style="font-size:18px;">
</span>
<span style="font-size:18px;"></span><pre class="cpp" name="code">#include <iostream>
#include <cstdio>
#include <cmath>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long LL;
const int maxn = 500000+10;
int city[maxn], arry[maxn];

int sear(int num, int l, int r)
{
    while( l<=r )
    {
        int mid = (l+r)/2;
        if( num >= arry[mid] )
            l = mid+1;
        else
            r = mid-1;
    }
    return l;
}

int DP(int n)
{
    memset(arry,0,sizeof(arry));
    arry[1] = city[1];
    int len=1;
    for( int i=2; i<=n; i++ )
    {

        if(city[i] > arry[len])
            arry[++len] = city[i];
        else
        {
            int low = sear(city[i], 1, len);
            arry[low] = city[i];
        }
    }
    return len;
}

int main()
{
    int n,k=1;
    while(~scanf("%d",&n))
    {
        memset(city,0,sizeof(city));
        for( int i=1; i<=n; i++ )
        {
            int x, y;
            scanf("%d%d",&x, &y);
            city[x] = y;
        }
        int MAX = DP(n);
        printf("Case %d:\n",k++);
        if( MAX==1 )
            printf("My king, at most 1 road can be built.\n\n");
        else
            printf("My king, at most %d roads can be built.\n\n",MAX);
    }
    return 0;
}






</pre><pre class="html" name="code" snippet_file_name="blog_20160808_7_18629" code_snippet_id="1816500">


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章