HDU1031——Design T-Shirt(結構體排序)

Design T-Shirt

猜猜我是誰

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 8364    Accepted Submission(s): 3997


Problem Description

Soon after he decided to design a T-shirt for our Algorithm Board on Free-City BBS, XKA found that he was trapped by all kinds of suggestions from everyone on the board. It is indeed a mission-impossible to have everybody perfectly satisfied. So he took a poll to collect people's opinions. Here are what he obtained: N people voted for M design elements (such as the ACM-ICPC logo, big names in computer science, well-known graphs, etc.). Everyone assigned each element a number of satisfaction. However, XKA can only put K (<=M) elements into his design. He needs you to pick for him the K elements such that the total number of satisfaction is maximized.

 


Input

The input consists of multiple test cases. For each case, the first line contains three positive integers N, M and K where N is the number of people, M is the number of design elements, and K is the number of elements XKA will put into his design. Then N lines follow, each contains M numbers. The j-th number in the i-th line represents the i-th person's satisfaction on the j-th element.

 


Output

For each test case, print in one line the indices of the K elements you would suggest XKA to take into consideration so that the total number of satisfaction is maximized. If there are more than one solutions, you must output the one with minimal indices. The indices start from 1 and must be printed in non-increasing order. There must be exactly one space between two adjacent indices, and no extra space at the end of the line.

 


Sample Input

3 6 4 2 2.5 5 1 3 4 5 1 3.5 2 2 2 1 1 1 1 1 10 3 3 2 1 2 3 2 3 1 3 1 2

 


Sample Output

6 5 3 1 2 1
題意:
有n個人對m件衣服評價,求最高的k件衣服的編號,並且把編號從大到小輸出,若評價相等,輸出編號較小的。
解題思路:
用結構體保存每件衣服的總評價,並記錄編號,根據評價按升序排衣服編號,取前k個編號倒敘輸出(很巧妙的解決了輸出編號小的問題)。
代碼實現:
#include <iostream>
#include <cstdio>
#include <cmath>
#include <queue>
#include <cstring>
#include <algorithm>

using namespace std;
typedef long long LL;
const int maxn = 100+10;
double mp[maxn];
int ans[maxn];
int n, m, k;

struct node
{
    double val=0;
    int num;
}p[maxn];

int cmp(const node a, const node b)
{
    return a.val>b.val;
}

int cmp2(const int a, const int b)
{
    return a>b;
}

int main()
{
    while( ~scanf("%d%d%d",&n,&m,&k))
    {
        memset(mp,0,sizeof(mp));
        memset(ans,0,sizeof(ans));
        for( int i=0; i<m; i++ )
            p[i].val = 0;
        for( int i=0; i<n; i++ )
        {
            for(int j=0; j<m; j++ )
            {
                double u;
                scanf("%lf",&u);
                p[j].val += u;             // 把每件衣服評價相加求總和;
                p[j].num = j+1;            // 保存衣服編號;
            }
        }
        sort(p,p+m,cmp);                   //按評價降序排序;
        //for(int i=0; i<m; i++ )
        //    cout << p[i].num <<" ";
        //cout<< endl;
        for( int i=0; i<k; i++ )
            ans[i] = p[i].num;            // 保存評價降序前k個編號;
        sort(ans,ans+m,cmp2);             // 排序編號輸出;
        int i;
        for( i=0; i<k-1; i++ )
            printf("%d ",ans[i]);
        printf("%d\n",ans[i]);
    }
    return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章