HDU1026(Ignatius and the Princess I)

Ignatius and the Princess I

Problem Description
The Princess has been abducted by the BEelzebub feng5166, our hero Ignatius has to rescue our pretty Princess. Now he gets into feng5166’s castle. The castle is a large labyrinth. To make the problem simply, we assume the labyrinth is a N*M two-dimensional array which left-top corner is (0,0) and right-bottom corner is (N-1,M-1). Ignatius enters at (0,0), and the door to feng5166’s room is at (N-1,M-1), that is our target. There are some monsters in the castle, if Ignatius meet them, he has to kill them. Here is some rules:

1.Ignatius can only move in four directions(up, down, left, right), one step per second. A step is defined as follow: if current position is (x,y), after a step, Ignatius can only stand on (x-1,y), (x+1,y), (x,y-1) or (x,y+1).
2.The array is marked with some characters and numbers. We define them like this:
. : The place where Ignatius can walk on.
X : The place is a trap, Ignatius should not walk on it.
n : Here is a monster with n HP(1<=n<=9), if Ignatius walk on it, it takes him n seconds to kill the monster.

Your task is to give out the path which costs minimum seconds for Ignatius to reach target position. You may assume that the start position and the target position will never be a trap, and there will never be a monster at the start position.

Input
The input contains several test cases. Each test case starts with a line contains two numbers N and M(2<=N<=100,2<=M<=100) which indicate the size of the labyrinth. Then a N*M two-dimensional array follows, which describe the whole labyrinth. The input is terminated by the end of file. More details in the Sample Input.

Output
For each test case, you should output “God please help our poor hero.” if Ignatius can’t reach the target position, or you should output “It takes n seconds to reach the target position, let me show you the way.”(n is the minimum seconds), and tell our hero the whole path. Output a line contains “FINISH” after each test case. If there are more than one path, any one is OK in this problem. More details in the Sample Output.

Sample Input

5 6
.XX.1.
…X.2.
2…X.
…XX.
XXXXX.
5 6
.XX.1.
…X.2.
2…X.
…XX.
XXXXX1
5 6
.XX…
…XX1.
2…X.
…XX.
XXXXX.

Sample Output
It takes 13 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
FINISH
It takes 14 seconds to reach the target position, let me show you the way.
1s:(0,0)->(1,0)
2s:(1,0)->(1,1)
3s:(1,1)->(2,1)
4s:(2,1)->(2,2)
5s:(2,2)->(2,3)
6s:(2,3)->(1,3)
7s:(1,3)->(1,4)
8s:FIGHT AT (1,4)
9s:FIGHT AT (1,4)
10s:(1,4)->(1,5)
11s:(1,5)->(2,5)
12s:(2,5)->(3,5)
13s:(3,5)->(4,5)
14s:FIGHT AT (4,5)
FINISH
God please help our poor hero.
FINISH

思路

這道題比較囉嗦,又是救人又是戰鬥的。最後還要輸出過程,由於這道題有戰鬥這個環節可能會影響時間的長短,所以需要用優先隊列維護這個搜索過程了。然後記錄座標和時間。最後找到的時候直接按要求輸出即可。這道題搜索過程走的路有點曲折,數組開小了導致TLE好幾發沒找到。具體也忘了幾個月前做的,現在集中補博客。

#include <iostream>
#include <algorithm>
#include <cstring>
#include <cstdio>
#include <queue>
#include <cmath>
using namespace std;
struct Node{
    int x,y,s,cnt;
    int stepx[1015],stepy[1105];			//開大一點
    bool operator< (const Node &a)const{
        if(a.s == s){
            return a.cnt < cnt;
        }
        else{
            return a.s < s;
        }
    }
};
char map[1105][1015];
bool visited[1105][1105];
int n,m;
int dx[] = {1,0,-1,0};
int dy[] = {0,1,0,-1};
int BFS()
{
    priority_queue<Node>q;
    while(!q.empty()){
        q.pop();
    }
    Node t;t.x = 0;t.y = 0;t.s = 0;t.cnt = 0;
    t.stepx[0] = 0;t.stepy[0] = 0;
    visited[t.x][t.y] = true;
    q.push(t);
    while(!q.empty()){
        Node p = q.top();
        q.pop();
        if(p.x == n-1 && p.y == m-1){
            printf("It takes %d seconds to reach the target position, let me show you the way.\n",p.s);
            int sum = 0;
            for(int i = 1;i <= p.cnt;i++){
                printf("%ds:(%d,%d)->(%d,%d)\n",sum+i,p.stepx[i-1],p.stepy[i-1],p.stepx[i],p.stepy[i]);
                if(map[p.stepx[i]][p.stepy[i]] >= '1' && map[p.stepx[i]][p.stepy[i]] <= '9'){
                    int k = map[p.stepx[i]][p.stepy[i]] - '0';
                    for(int j = 0;j < k;j++){
                        printf("%ds:FIGHT AT (%d,%d)\n",sum+i+1+j,p.stepx[i],p.stepy[i]);
                    }
                    sum += k;
                }
            }
            return 1;
        }
        t = p;
        for(int i = 0;i < 4;i++){
            t.x = p.x + dx[i];
            t.y = p.y + dy[i];
            if(t.x < 0 || t.x >= n || t.y < 0 || t.y >= m || visited[t.x][t.y] == true || map[t.x][t.y] == 'X'){
                continue;
            }
            t.cnt = p.cnt + 1; 
            t.stepx[t.cnt] = t.x;
            t.stepy[t.cnt] = t.y;
            t.s = p.s + 1;
            if(map[t.x][t.y] >= '1' && map[t.x][t.y] <= '9'){
                t.s = t.s + map[t.x][t.y] - '0';
            }
            visited[t.x][t.y] = true;
            q.push(t);
        }
    }
    return 0;
}
int main()
{
    while(~scanf("%d%d",&n,&m)){
        for(int i = 0;i < n;i++){
            scanf("%s",map[i]);
        }
    //    m = strlen(map[0]);
        memset(visited,false,sizeof(visited));
        int ans = BFS();
        if(ans == 0){
            printf("God please help our poor hero.\n");
        }
        printf("FINISH\n");
    }
    return 0;
}

願你走出半生,歸來仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章