HDU1686(Oulipo)

Oulipo

Problem Description

The French author Georges Perec (1936–1982) once wrote a book, La disparition, without the letter ‘e’. He was a member of the Oulipo group. A quote from the book:

Tout avait Pair normal, mais tout s’affirmait faux. Tout avait Fair normal, d’abord, puis surgissait l’inhumain, l’affolant. Il aurait voulu savoir où s’articulait l’association qui l’unissait au roman : stir son tapis, assaillant à tout instant son imagination, l’intuition d’un tabou, la vision d’un mal obscur, d’un quoi vacant, d’un non-dit : la vision, l’avision d’un oubli commandant tout, où s’abolissait la raison : tout avait l’air normal mais…

Perec would probably have scored high (or rather, low) in the following contest. People are asked to write a perhaps even meaningful text on some subject with as few occurrences of a given “word” as possible. Our task is to provide the jury with a program that counts these occurrences, in order to obtain a ranking of the competitors. These competitors often write very long texts with nonsense meaning; a sequence of 500,000 consecutive 'T’s is not unusual. And they never use spaces.

So we want to quickly find out how often a word, i.e., a given string, occurs in a text. More formally: given the alphabet {‘A’, ‘B’, ‘C’, …, ‘Z’} and two finite strings over that alphabet, a word W and a text T, count the number of occurrences of W in T. All the consecutive characters of W must exactly match consecutive characters of T. Occurrences may overlap.

Input

The first line of the input file contains a single number: the number of test cases to follow. Each test case has the following format:
One line with the word W, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with 1 ≤ |W| ≤ 10,000 (here |W| denotes the length of the string W).
One line with the text T, a string over {‘A’, ‘B’, ‘C’, …, ‘Z’}, with |W| ≤ |T| ≤ 1,000,000.

Output

For every test case in the input file, the output should contain a single number, on a single line: the number of occurrences of the word W in the text T.

Sample Input

3
BAPC
BAPC
AZA
AZAZAZA
VERDI
AVERDXIVYERDIAN

Sample Output

1
3
0

思路

給定一個模式串和一個主串問模式串在主串中出現了幾次,典型的KMP算法next數組的使用,考察對next數組的理解,最後一個字符匹配成功說明出現次數+1這時候將模式串的下標置爲j = next[j]。也就是
相當於現在事情都沒發生,最後一個字符失配。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
char s[1000005],p[10005];
int num[10005];
void get_next()
{
	memset(num,-1,sizeof(num));
	int n = strlen(p);
	int j = -1,i = 0;
	while(i < n){
		if(j == -1 || p[j] == p[i]){
			i++;j++;
			num[i] = j; 
		}
		else{
			j = num[j];
		}
	}
}
int kmp()
{
	int n = strlen(s);
	int m = strlen(p);
	int i = 0,j = 0;
	int cnt = 0;
	while(i < n){
		if(j == m-1 && s[i] == p[j]){
			cnt++;j = num[j];
		} 
		if(j == -1 || s[i] == p[j]){
			i++;j++;
		}
		else{
			j = num[j];
		}
	}
	return cnt;
}
int main()
{
	int t;
	scanf("%d",&t);
	while(t--){
		scanf("%s %s",p,s);
		get_next();
		int ans = kmp();
		printf("%d\n",ans);
	}
	return 0;
}

願你走出半生,歸來仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章