HDU1358(Period)

Period

Problem Description

For each prefix of a given string S with N characters (each character has an ASCII code between 97 and 126, inclusive), we want to know whether the prefix is a periodic string. That is, for each i (2 <= i <= N) we want to know the largest K > 1 (if there is one) such that the prefix of S with length i can be written as AK , that is A concatenated K times, for some string A. Of course, we also want to know the period K.

Input

The input file consists of several test cases. Each test case consists of two lines. The first one contains N (2 <= N <= 1 000 000) – the size of the string S. The second line contains the string S. The input file ends with a line, having the number zero on it.

Output

For each test case, output “Test case #” and the consecutive test case number on a single line; then, for each prefix with length i that has a period K > 1, output the prefix size i and the period K separated by a single space; the prefix sizes must be in increasing order. Print a blank line after each test case.

Sample Input

3
aaa
12
aabaabaabaab
0

Sample Output

Test case #1
2 2
3 3

Test case #2
2 2
6 2
9 3
12 4

思路

給定一組字符串問這串字符串的子串在哪個位置可以形成兩個以上的循環節,利用KMP的next數組的特性j - next[j]是循環節長度,如果j % (j-next[j]) == 0說明是整數倍,輸出即可。

#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
using namespace std;
const int maxn = 1000005;
char s[maxn];
int num[maxn];
void get_next(int n)
{
	memset(num,-1,sizeof(num));
	int i = 0,j = -1;
	while(i < n){
		if(j == -1 || s[i] == s[j]){
			i++;j++;
			num[i] = j;
		}
		else{
			j = num[j];
		}
	} 
}
int main()
{
	int n,k = 1;
	while(~scanf("%d",&n) && n){
		scanf("%s",s);
		get_next(n);
		printf("Test case #%d\n",k++);
		for(int i = 1;i <= n;i++){
			if(num[i]){
				int ans = i - num[i];		//循環節的長度	
				if(i%ans == 0){
					printf("%d %d\n",i,i/ans); 
				}
			}
		}
		printf("\n");
	}
	return 0;
}

願你走出半生,歸來仍是少年~

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章