關於USACO

這是第一道。。。以這道題目舉例
Your Ride Is Here

It is a well-known fact that behind every good comet is a UFO. These UFOs often come to collect loyal supporters from here on Earth. Unfortunately, they only have room to pick up one group of followers on each trip. They do, however, let the groups know ahead of time which will be picked up for each comet by a clever scheme: they pick a name for the comet which, along with the name of the group, can be used to determine if it is a particular group’s turn to go (who do you think names the comets?). The details of the matching scheme are given below; your job is to write a program which takes the names of a group and a comet and then determines whether the group should go with the UFO behind that comet.

Both the name of the group and the name of the comet are converted into a number in the following manner: the final number is just the product of all the letters in the name, where “A” is 1 and “Z” is 26. For instance, the group “USACO” would be 21 * 19 * 1 * 3 * 15 = 17955. If the group’s number mod 47 is the same as the comet’s number mod 47, then you need to tell the group to get ready! (Remember that “a mod b” is the remainder left over after dividing a by b; 34 mod 10 is 4.)

Write a program which reads in the name of the comet and the name of the group and figures out whether according to the above scheme the names are a match, printing “GO” if they match and “STAY” if not. The names of the groups and the comets will be a string of capital letters with no spaces or punctuation, up to 6 characters long.

Examples:

Input Output
COMETQ
HVNGAT

GO
ABSTAR
USACO
STAY

PROGRAM NAME: ride
This means that you fill in your header with:
PROG: ride
WARNING: You must have ‘ride’ in this field or the wrong test data (or no test data) will be used.
INPUT FORMAT

Line 1: An upper case character string of length 1..6 that is the name of the comet.
Line 2: An upper case character string of length 1..6 that is the name of the group.

NOTE: The input file has a newline at the end of each line but does not have a “return”. Sometimes, programmers code for the Windows paradigm of “return” followed by “newline”; don’t do that! Use simple input routines like “readln” (for Pascal) and, for C/C++, “fscanf” and “fid>>string”.

NOTE 2: Because of the extra characters, be sure to leave enough room for a ‘newline’ (also notated as ‘\n’) and an end of string character (‘\0’) if your language uses it (as C and C++ do). This means you need eight characters of room instead of six.

SAMPLE INPUT (file ride.in)
COMETQ
HVNGAT

OUTPUT FORMAT
A single line containing either the word “GO” or the word “STAY”.
SAMPLE OUTPUT (file ride.out)
GO

OUTPUT EXPLANATION
Converting the letters to numbers:

C O M E T Q
3 15 13 5 20 17

H V N G A T
8 22 14 7 1 20
then calculate the product mod 47: 3 * 15 * 13 * 5 * 20 * 17 = 994500 mod 47 = 27
8 * 22 * 14 * 7 * 1 * 20 = 344960 mod 47 = 27

Because both products evaluate to 27 (when modded by 47), the mission is ‘GO’.

中文翻譯
Your Ride Is Here
你要乘坐的飛碟在這裏
譯 by tim green
一個衆所周知的事實,在每一慧星後面是一個不明飛行物UFO。 這些不明飛行物時常來收集來自在地球上忠誠的支持者。 不幸地,他們的空間在每次旅行只能帶上一羣支持者。 他們要做的是用一種聰明的方案讓每一個團體人被慧星帶走。 他們爲每個慧星起了一個名字,通過這些名字來決定一個團體是不是特定的慧星帶走。 那個相配方案的細節在下面被給出; 你的工作要寫一個程序來通過團體的名字和彗星的名字來決定一個組是否應該與在那一顆慧星後面的不明飛行物搭配。 團體的名字和慧星的名字都以下列各項方式轉換成一個數字: 這個最後的數字代表名字中所有字母的信息,”A” 是 1 和 “Z” 是 26。 舉例來說,團體 “USACO” 會是 21*19*1*3*15=17955 。 如果團體的數字 mod 47 等於慧星的數字 mod 47,那麼你要告訴這個團體準備好被帶走 ! 寫一個程序讀入慧星的名字和團體的名字,如果搭配打印”GO”否者打印”STAY” 團體的名字和慧星的名字將會是有沒有空格或標點的一串大寫字母(不超過6個字母),
Examples:
Input Output
COMETQ

HVNGAT GO
ABSTAR

USACO STAY
PROGRAM NAME: ride
INPUT FORMAT
第 1 行: 彗星的名字(一個長度爲1到6的字符串)
第 2 行: 團體的名字(一個長度爲1到6的字符串)
SAMPLE INPUT (file ride.in
COMETQ
HVNGAT
OUTPUT FORMAT
單獨一行包含”STAR”或”GO”.
SAMPLE OUTPUT (file ride.out)
GO

注意點
1.首先這個提交是要用文件,,,就像正規考試一樣,cpp文件他有給
文件名,比如這個就是ride,,讀入文件就是ride.in,ride.out..這個和一般的OJ網站不同。。。
2.這個需要在代碼前寫上一些東西,比如這個AC的代碼
/*
ID:**就是你的id
LANG:C++
TASK:ride
*/
ID:就是你的ID
LANG:要大些
TASK:就是問題名字

/*
ID:****就是你的id
LANG:C++
TASK:ride 
*/
#include<iostream>
#include<cstdio>
#include<cstring>
using namespace std;
char s1[8],s2[8];
const int mod=47;
int main(){
    freopen("ride.in","r",stdin);
    freopen("ride.out","w",stdout);
    scanf("%s",s1);
    scanf("%s",s2);
    int ans1=1,ans2=1;
    int a=strlen(s1),b=strlen(s2);
    for(int i = 0; i<a;i++)
        ans1=ans1 * (s1[i]-'A'+1)%mod;
    for(int i = 0; i<b;i++)
        ans2=ans2 * (s2[i]-'A'+1)%mod;
    if(ans1==ans2)printf("GO\n");
    else printf("STAY\n");
    return 0;
}

其實這個網站很好的地方是你錯了那組數據他會給你,很不錯,QAQ,不過不要直接printf,,,會被封號的。。。。

要數據的評論

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章