[USACO]Barn Repair

Barn Repair

It was a dark and stormy night that ripped the roof and gates off the stalls that hold Farmer John's cows. Happily, many of the cows were on vacation, so the barn was not completely full.

The cows spend the night in stalls that are arranged adjacent to each other in a long line. Some stalls have cows in them; some do not. All stalls are the same width.

Farmer John must quickly erect new boards in front of the stalls, since the doors were lost. His new lumber supplier will supply him boards of any length he wishes, but the supplier can only deliver a small number of total boards. Farmer John wishes to minimize the total length of the boards he must purchase.

Given M (1 <= M <= 50), the maximum number of boards that can be purchased; S (1 <= S <= 200), the total number of stalls; C (1 <= C <= S) the number of cows in the stalls, and the C occupied stall numbers (1 <= stall_number <= S), calculate the minimum number of stalls that must be blocked in order to block all the stalls that have cows in them.

Print your answer as the total number of stalls blocked.

PROGRAM NAME: barn1

INPUT FORMAT

Line 1: M, S, and C (space separated)
Lines 2-C+1: Each line contains one integer, the number of an occupied stall.

SAMPLE INPUT (file barn1.in)

4 50 18
3
4
6
8
14
15
16
17
21
25
26
27
30
31
40
41
42
43

OUTPUT FORMAT

A single line with one integer that represents the total number of stalls blocked.

SAMPLE OUTPUT (file barn1.out)

25

[One minimum arrangement is one board covering stalls 3-8, one covering 14-21, one covering 25-31, and one covering 40-43.] 


import java.io.BufferedReader;
import java.io.FileNotFoundException;
import java.io.FileReader;
import java.io.FileWriter;
import java.io.IOException;

public class barn1 {

	/**
	 * @param args
	 * @throws IOException,FileNotFoundException
	 */
	public static void main(String[] args) throws IOException,FileNotFoundException {
		// TODO Auto-generated method stub
		BufferedReader br = new BufferedReader(new FileReader("barn1.in"));
		FileWriter fout = new FileWriter("barn1.out");
		//params:amount of stalls;total number barns;broken barns number;
		String[] sParams = br.readLine().split(" ");
		int[] nParams = new int[sParams.length];
		for(int i=0;i<sParams.length;i++){
			nParams[i] = Integer.parseInt(sParams[i]);
		}
		int[] barns = new int[nParams[1]];
		int tmp;
		//ExceptionCatching:
		for(int i = 0;i<nParams[2];i++){
			tmp = Integer.parseInt(br.readLine());
			barns[tmp-1]=1;//the value of position should't be 1 before set to 1; 
		}
		//sort the largest nParams[0]-1 slot that there was no broken barn except for head and tail.
		fout.write(Cover_Barns(barns,nParams[0])+"\n");
		fout.close();
		br.close();
		System.exit(0);
	}

	private static int Cover_Barns(int[] barns, int topN) {
		// TODO Auto-generated method stub
		if(!(barns.length>1) || topN<1){
			return -1;
		}
		//topN-1 store tail
		int[] aTopN = new int[topN];
		int head =0;
		int p =0;
		int tmp = 0;
		while(barns[p]==0){
			p++;
		}
		head = p;
		for(;p<barns.length;p++){
			if(barns[p]==0){
				tmp++;
			}else if(tmp>0){
				insert(aTopN,tmp);
				tmp =0;
			}
		}
		aTopN[aTopN.length-1] = tmp;
		return barns.length-sum(aTopN)-head;
	}

	private static int sum(int[] aTopN) {
		// TODO Auto-generated method stub
		int sum = 0;
		for(int i = 0;i<aTopN.length;i++){
			sum += aTopN[i];
		}
		return sum;
	}

	private static void insert(int[] aTopN, int tmp) {
		// TODO Auto-generated method stub
		aTopN[aTopN.length-1] = tmp;
		for(int j = aTopN.length-1;j>0&&aTopN[j]>aTopN[j-1];j--){
			swap(aTopN,j,j-1);
		}
	}

	private static void swap(int[] aTopN, int j, int i) {
		// TODO Auto-generated method stub
		aTopN[j] = aTopN[j] - aTopN[i];
		aTopN[i] = aTopN[j] + aTopN[i];
		aTopN[j] = aTopN[i] - aTopN[j];
	}

}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章