POJ3041:Asteroids

點擊打開題目鏈接


Asteroids

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 12568   Accepted: 6829

Description

Bessie wants to navigate her spaceship through a dangerous asteroid field in the shape of an N x N grid (1 <= N <= 500). The grid contains K asteroids (1 <= K <= 10,000), which are conveniently located at the lattice points of the grid. 

Fortunately, Bessie has a powerful weapon that can vaporize all the asteroids in any given row or column of the grid with a single shot.This weapon is quite expensive, so she wishes to use it sparingly.Given the location of all the asteroids in the field, find the minimum number of shots Bessie needs to fire to eliminate all of the asteroids.

Input

* Line 1: Two integers N and K, separated by a single space. 
* Lines 2..K+1: Each line contains two space-separated integers R and C (1 <= R, C <= N) denoting the row and column coordinates of an asteroid, respectively.

Output

* Line 1: The integer representing the minimum number of times Bessie must shoot.

Sample Input

3 4
1 1
1 3
2 2
3 2

Sample Output

2

Hint

INPUT DETAILS: 
The following diagram represents the data, where "X" is an asteroid and "." is empty space: 
X.X 
.X. 
.X.
 

OUTPUT DETAILS: 
Bessie may fire across row 1 to destroy the asteroids at (1,1) and (1,3), and then she may fire down column 2 to destroy the asteroids at (2,2) and (3,2).

Source


=====================================題目大意=====================================


Bessie需要駕駛她的宇宙飛船冒着危險穿越一片有着K個小行星的規格爲N X N的網狀型小行星帶。

幸好Bessie的宇宙飛船裝備了可以蒸發某一行或某一列上所有小行星的強大武器。

但是使用武器的花費相當昂貴,Bessie希望節約得使用,請幫助她計算蒸發小行星帶中所有小行星所需要使用武器的最少次數。


=====================================算法分析=====================================


二分圖最大匹配的König定理:最小點覆蓋數 = 最大匹配數。


=======================================代碼=======================================




#include<stdio.h>
#include<string.h>

int N,K,Linker[505];

bool Edge[505][505],Vis[505];

bool DFS(int U)
{
	for(int v=1;v<=N;++v)
	{
		if(Edge[U][v]&&!Vis[v])
		{
			Vis[v]=true;
			if(Linker[v]==-1||DFS(Linker[v]))
			{
				Linker[v]=U;
				return true;
			}
		}
	}
	return false;
}

int Hungary()
{
	memset(Linker,-1,sizeof(Linker));
	int ans=0;
	for(int u=1;u<=N;++u)
	{
		memset(Vis,0,sizeof(Vis));
		if(DFS(u)) { ++ans; }
	}
	return ans;
}

int main()
{
	while(scanf("%d%d",&N,&K)==2)
	{
		memset(Edge,0,sizeof(Edge));
		for(int i=0;i<K;++i)
		{
			int row,col;
			scanf("%d%d",&row,&col);
			Edge[row][col]=true;
		}
		printf("%d\n",Hungary());
	}
	return 0;
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章