uva572 Oil Deposits

A - Oil Deposits
Time Limit:3000MS    Memory Limit:0KB    64bit IO Format:%lld & %llu

Description

Download as PDF

The GeoSurvComp geologic survey company is responsible for detecting underground oil deposits. GeoSurvComp works with one large rectangular region of land at a time, and creates a grid that divides the land into numerous square plots. It then analyzes each plot separately, using sensing equipment to determine whether or not the plot contains oil.

A plot containing oil is called a pocket. If two pockets are adjacent, then they are part of the same oil deposit. Oil deposits can be quite large and may contain numerous pockets. Your job is to determine how many different oil deposits are contained in a grid.

Input 

The input file contains one or more grids. Each grid begins with a line containing m and n, the number of rows and columns in the grid, separated by a single space. If m = 0 it signals the end of the input; otherwise $1 \le m \le 100$ and $1 \le n \le 100$. Following this are m lines of n characters each (not counting the end-of-line characters). Each character corresponds to one plot, and is either ` *', representing the absence of oil, or ` @', representing an oil pocket.

Output 

For each grid, output the number of distinct oil deposits. Two different pockets are part of the same oil deposit if they are adjacent horizontally, vertically, or diagonally. An oil deposit will not contain more than 100 pockets.

Sample Input 

1 1
*
3 5
*@*@*
**@**
*@*@*
1 8
@@****@*
5 5
****@
*@@*@
*@**@
@@@*@
@@**@
0 0

Sample Output 

0
1
2
2


簡單的圖

判斷有幾個不相連的油田


讀下來

從第一個點開始

如果這個點是@並且沒走過

cnt++

然後dfs周圍的八個點


要把圖像移動下

不然的數組會越界RE



#include <stdio.h>
#include <string.h>

char sen[120];
int flag[120][120], map[120][120];

void dfs(int x, int y){
	if (flag[x][y] || !map[x][y])
		return ;
	flag[x][y] = 1;
	dfs(x - 1, y);
	dfs(x + 1, y);
	dfs(x, y - 1);
	dfs(x, y + 1);
	dfs(x - 1, y - 1);
	dfs(x - 1, y + 1);
	dfs(x + 1, y - 1);
	dfs(x + 1, y + 1);
}

int main(){
	int n, m;
	while (scanf("%d %d", &n, &m) && n && m) {
		getchar();
		int cnt = 0;
		memset(map, 0, sizeof(map));
		memset(flag, 0, sizeof(flag));
		for (int i = 0; i < n; i++) {
			gets(sen);
			for (int j = 0; j < strlen(sen); j++) 
				if (sen[j] == '@')
					map[i + 1][j + 1] = 1;
		}

		for (int i = 1; i <= n; i++)
			for (int j = 1; j <= m; j++) {
				if (map[i][j] && !flag[i][j]) {
					cnt++;
					dfs(i, j);
				}
			}
		printf("%d\n", cnt);
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章