poj 1325 Machine Schedule(二分圖的最小點覆蓋)

Machine Schedule
Time Limit: 1000MS   Memory Limit: 10000K
Total Submissions: 12035   Accepted: 5129

Description

As we all know, machine scheduling is a very classical problem in computer science and has been studied for a very long history. Scheduling problems differ widely in the nature of the constraints that must be satisfied and the type of schedule desired. Here we consider a 2-machine scheduling problem. 

There are two machines A and B. Machine A has n kinds of working modes, which is called mode_0, mode_1, ..., mode_n-1, likewise machine B has m kinds of working modes, mode_0, mode_1, ... , mode_m-1. At the beginning they are both work at mode_0. 

For k jobs given, each of them can be processed in either one of the two machines in particular mode. For example, job 0 can either be processed in machine A at mode_3 or in machine B at mode_4, job 1 can either be processed in machine A at mode_2 or in machine B at mode_4, and so on. Thus, for job i, the constraint can be represent as a triple (i, x, y), which means it can be processed either in machine A at mode_x, or in machine B at mode_y. 

Obviously, to accomplish all the jobs, we need to change the machine's working mode from time to time, but unfortunately, the machine's working mode can only be changed by restarting it manually. By changing the sequence of the jobs and assigning each job to a suitable machine, please write a program to minimize the times of restarting machines. 

Input

The input file for this program consists of several configurations. The first line of one configuration contains three positive integers: n, m (n, m < 100) and k (k < 1000). The following k lines give the constrains of the k jobs, each line is a triple: i, x, y. 

The input will be terminated by a line containing a single zero. 

Output

The output should be one integer per line, which means the minimal times of restarting machine.

Sample Input

5 5 10
0 1 1
1 1 2
2 1 3
3 1 4
4 2 1
5 2 2
6 2 3
7 2 4
8 3 3
9 4 3
0

Sample Output

3

Source

不得不說自己並沒有很好的理解二分圖,在網絡流的題目中參雜了好多二分圖的題目,竟一時不知怎麼做了;

題目大意:k個job要做,第i個job可以在A機器的xmod上完成,也可在B機器上的mody上完成。每次轉換模式都需要重新啓動一次機器,問最少需要多少次啓動;
看似好像有點最小點覆蓋的意思了;
最小點覆蓋是指:無向圖中,最少需要多少個點可以覆蓋所有的邊。一條邊被覆蓋是指至少有一個和它相鄰的點被選中;
最小點覆蓋=最大匹配數;證明:http://www.matrix67.com/blog/archives/116
匈牙利算法求最大匹配數;
注意此題開始時A,B都從mod0開始的;
代碼:
#include <iostream>
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#define max(a,b) a>b?a:b
#define min(a,b) a<b?a:b
#define N 110
using namespace std;
int map[N][N];
int lef[N];
int vis[N],nx,ny;
int dfs(int x)
{
    for(int i=1;i<=ny;i++)
    {
        if(!vis[i]&&map[x][i])
        {
            vis[i]=1;
            if(lef[i]==0||dfs(lef[i]))
            {
                lef[i]=x;
                return true;
            }
        }
    }
    return false;
}
int nmatch()
{
    int i,ans=0;

    for(i=1;i<=nx;i++)
    {
        memset(vis,0,sizeof(vis));
        if(dfs(i))
            ans++;
    }
    return ans;
}
int main()
{
    int n,m,k,x,y,i,j;
    while(~scanf("%d",&n)&&n)
    {
        scanf("%d%d",&m,&k);
        nx=n,ny=m;
        memset(map,0,sizeof(map));
        memset(lef,0,sizeof(lef));
        for(i=0;i<k;i++)
        {
            scanf("%d%d%d",&j,&x,&y);
            map[x][y]=1;
        }
        int ans=nmatch();
        printf("%d\n",ans);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章