bfs+玄學去重——鑰匙開門hdu 1885

                                                    Key Task

The Czech Technical University is rather old — you already know that it celebrates 300 years of its existence in 2007. Some of the university buildings are old as well. And the navigation in old buildings can sometimes be a little bit tricky, because of strange long corridors that fork and join at absolutely unexpected places. 

The result is that some first-graders have often di?culties finding the right way to their classes. Therefore, the Student Union has developed a computer game to help the students to practice their orientation skills. The goal of the game is to find the way out of a labyrinth. Your task is to write a verification software that solves this game. 

The labyrinth is a 2-dimensional grid of squares, each square is either free or filled with a wall. Some of the free squares may contain doors or keys. There are four di?erent types of keys and doors: blue, yellow, red, and green. Each key can open only doors of the same color. 

You can move between adjacent free squares vertically or horizontally, diagonal movement is not allowed. You may not go across walls and you cannot leave the labyrinth area. If a square contains a door, you may go there only if you have stepped on a square with an appropriate key before.

Input

The input consists of several maps. Each map begins with a line containing two integer numbers R and C (1 ≤ R, C ≤ 100) specifying the map size. Then there are R lines each containing C characters. Each character is one of the following: 



Note that it is allowed to have 

  • more than one exit,
  • no exit at all,
  • more doors and/or keys of the same color, and
  • keys without corresponding doors and vice versa.


     
  • You may assume that the marker of your position (“*”) will appear exactly once in every map. 

    There is one blank line after each map. The input is terminated by two zeros in place of the map size.

Output

For each map, print one line containing the sentence “Escape possible in S steps.”, where S is the smallest possible number of step to reach any of the exits. If no exit can be reached, output the string “The poor student is trapped!” instead. 

One step is defined as a movement between two adjacent cells. Grabbing a key or unlocking a door does not count as a step.

Sample Input

1 10
*........X

1 3
*#X

3 20
####################
#XY.gBr.*.Rb.G.GG.y#
####################

0 0

Sample Output

Escape possible in 9 steps.
The poor student is trapped!
Escape possible in 45 steps.

開始以爲一把鑰匙開完一個門後就不能用了,然後注意到最後一組樣例T_T。

所以這個vis數組要用三維的,他表示的是每個點的擁有鑰匙的情況。

這裏的方法好玄學,用二進制的位表示是否擁有一把鑰匙^_^

個人感覺有點像hash去重

#include<cstdio>
#include<cstring>
#include<vector>
#include<queue>
#include<algorithm>
#include<iostream>
using namespace std;
const int maxn=1e2+5;
char a[maxn][maxn];
int vis[maxn][maxn][32];//在一個點對應的鑰匙有幾把
int sx,sy;
int n,m;
inline int to(char c)
{

    if(c=='b'||c=='B') return 0;
    if(c=='Y'||c=='y') return 1;
    if(c=='R'||c=='r') return 2;
    if(c=='g'||c=='G') return 3;
}
inline bool check(int x,int y)
{
    if(a[x][y]=='#') return false;
    if(x<0||y<0||x>=n||y>=m) return false;
    return true;
}
int dx[5]={0,0,-1,1};
int dy[5]={1,-1,0,0};
struct node
{
    int x,y;
    int st;
    int k;//點的去重標記
};
void bfs()
{
    node t;
    t.x=sx;
    t.y=sy;
    t.st=0;
    t.k=0;
    a[sx][sy]='.';
    memset(vis,0,sizeof vis);
    queue<node> q;
    vis[sx][sy][t.k]=1;
    q.push(t);
    while(!q.empty())
    {

        node f=q.front();
        //cout<<f.x<<' '<<f.y<<' '<<a[f.x][f.y]<<endl;
        q.pop();
        for(int i=0;i<4;++i)
        {
            int xx=f.x+dx[i];
            int yy=f.y+dy[i];
            if(check(xx,yy))//沒有出界
            {
                if(a[xx][yy]=='.'&&!vis[xx][yy][f.k])
                {
                    //cout<<yy<<endl;
                    vis[xx][yy][f.k]=1;
                    node temp;
                    temp.x=xx;
                    temp.y=yy;
                    temp.st=f.st+1;
                    temp.k=f.k;
                    q.push(temp);
                }
                else if(a[xx][yy]>='a'&&a[xx][yy]<='z')//判斷有沒有鑰匙
                {
                    int hh=1<<to(a[xx][yy]);
                    int tt=f.k;
                    if((f.k&hh)==0) //沒有這把鑰匙,加上這把鑰匙
                        tt+=hh;
                    //cout<<f.k<<endl;
                    if(!vis[xx][yy][tt])
                    {
                        //cout<<yy<<endl;
                        vis[xx][yy][tt]=1;
                        node temp;
                        temp.x=xx;
                        temp.y=yy;
                        temp.st=f.st+1;
                        temp.k=tt;
                        q.push(temp);
                    }
                }
                else if(a[xx][yy]>='A'&&a[xx][yy]<='Z')
                {

                    if(a[xx][yy]=='X')
                    {
                        printf("Escape possible in %d steps.\n",f.st+1);
                        return;
                    }
                    int hh=1<<to(a[xx][yy]);

                    if((hh&f.k)&&!vis[xx][yy][f.k])//有這把鑰匙並且沒來過
                    {
                        vis[xx][yy][f.k]=1;
                        //cout<<xx<<' '<<yy<<endl;
                        node temp;
                        temp.x=xx;
                        temp.y=yy;
                        temp.st=f.st+1;
                        temp.k=f.k;
                        q.push(temp);
                    }
                }
            }
        }
    }
    puts("The poor student is trapped!");
    return ;
}
int main()
{
    while(~scanf("%d%d",&n,&m)&&(n||m))
    {
        for(int i=0;i<n;++i)
            scanf("%s",a[i]);
        for(int i=0;i<n;++i)
            for(int j=0;j<m;++j)
            if(a[i][j]=='*')
        {
            sx=i;
            sy=j;
            break;
        }
        bfs();

    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章