poj2253---Frogger (最短路變形)一隻快樂的小青蛙

                                                              Frogger

Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 76896   Accepted: 23403

Description

Freddy Frog is sitting on a stone in the middle of a lake. Suddenly he notices Fiona Frog who is sitting on another stone. He plans to visit her, but since the water is dirty and full of tourists' sunscreen, he wants to avoid swimming and instead reach her by jumping. 
Unfortunately Fiona's stone is out of his jump range. Therefore Freddy considers to use other stones as intermediate stops and reach her by a sequence of several small jumps. 
To execute a given sequence of jumps, a frog's jump range obviously must be at least as long as the longest jump occuring in the sequence. 
The frog distance (humans also call it minimax distance) between two stones therefore is defined as the minimum necessary jump range over all possible paths between the two stones. 

You are given the coordinates of Freddy's stone, Fiona's stone and all other stones in the lake. Your job is to compute the frog distance between Freddy's and Fiona's stone. 

Input

The input will contain one or more test cases. The first line of each test case will contain the number of stones n (2<=n<=200). The next n lines each contain two integers xi,yi (0 <= xi,yi <= 1000) representing the coordinates of stone #i. Stone #1 is Freddy's stone, stone #2 is Fiona's stone, the other n-2 stones are unoccupied. There's a blank line following each test case. Input is terminated by a value of zero (0) for n.

Output

For each test case, print a line saying "Scenario #x" and a line saying "Frog Distance = y" where x is replaced by the test case number (they are numbered from 1) and y is replaced by the appropriate real number, printed to three decimals. Put a blank line after each test case, even after the last one.

Sample Input

2
0 0
3 4

3
17 4
19 4
18 5

0

Sample Output

Scenario #1
Frog Distance = 5.000

Scenario #2
Frog Distance = 1.414

已知湖裏有兩隻青蛙,位置分別是 1和 2 由於湖水的原因他們不能游泳,只能通過其他的石頭作爲墊腳石,跳過去找到他們夢寐以求的情侶,需要我們找到兩個石頭之間 可以連通的路徑中青蛙最大的單次跳躍距離最小,就是一個也是一個木桶短板效應,求得路徑上最小的最大距離

根據題意可以知道青蛙的最大跳躍距離並不受限制,即任意兩個石頭之間是相通的,因此可以不需要初始化 鄰接矩陣 

這個是求最小的最大距離,還有一個類似的題目是 求最大的最小值問題http://poj.org/problem?id=1797Heavy Transportation

可以參考的blog:https://blog.csdn.net/qq_44786250/article/details/104197223

但是這道題具有更大的優勢就是數據量比較小,可以使用暴力的Floyd算法,Dijkstra和SPFA同樣綽綽有餘

路徑更新時不需要更新可達路徑,dis數組表示的是從 1 到其他點的符合題目的最大最小距離

提醒:由於G++和C++對精度的要求不一樣,導致G++會被WA,反正是使用C++編譯器就對了 

Floyd:

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int mm=222;

int n;
double mp[mm][mm];
int x[mm],y[mm];
int t=1; 

int main()
{
	while(scanf("%d",&n)!=EOF&&n){
		for(int i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++)
				mp[i][j]=mp[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
		//floyd 
		for(int k=1;k<=n;k++)
			for(int i=1;i<=n;i++)
				for(int j=1;j<=n;j++)
					mp[i][j]=min(mp[i][j],max(mp[i][k],mp[k][j]));
										
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,mp[1][2]);
	}


	return 0;
}

Dijkstra:

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int mm=222;

int t=1;
int n,m;
int x[mm],y[mm];
double mp[mm][mm];
double dis[mm];
 
void dijkstra(){
	int book[mm]={0};
	for(int i=1;i<n;i++){
		double mint=inf;
		int u;
		for(int j=1;j<=n;j++)
			if(dis[j]<mint&&book[j]==0){
				u=j;
				mint=dis[j];
			}
		book[u]=1;
		for(int j=1;j<=n;j++)
			if(book[j]==0&&max(mp[u][j],dis[u])<dis[j])
				dis[j]=max(mp[u][j],dis[u]);
	}
} 

int main()
{
	while(scanf("%d",&n)!=EOF&&n){
//		for(int i=1;i<=n;i++)
//			for(int j=1;j<=n;j++)
//				mp[i][j]=i==j?0:inf;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++)
				mp[i][j]=mp[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
		for(int i=1;i<=n;i++)
			dis[i]=mp[1][i];
		
		dijkstra();
		
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,dis[2]);
	}

	return 0;
}

SPFA

#include<cstdio>
#include<string>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<vector>
#include<stack>
#include<queue>
#define ll long long
#define mem(a,b) memset(a,b,sizeof(a))
using namespace std;
const int inf=0x3f3f3f3f;
const int mm=222;

int t=1;
int n,m;
int x[mm],y[mm];
double mp[mm][mm];
double dis[mm];

void spfa(){
	int book[mm]={0};
	queue<int>q;
	q.push(1);
	book[1]=1;
	while(!q.empty()){
		int u=q.front();
		q.pop();
		book[u]=0;
		for(int j=1;j<=n;j++)
			if(max(dis[u],mp[u][j])<dis[j]){
				dis[j]=max(dis[u],mp[u][j]);
				if(book[j]==0){
					q.push(j);
					book[j]=1;
				}
			}
	}
}

int main()
{
	while(scanf("%d",&n)!=EOF&&n){
//		for(int i=1;i<=n;i++)
//			for(int j=1;j<=n;j++)
//				mp[i][j]=i==j?0:inf;
		for(int i=1;i<=n;i++)
			scanf("%d%d",&x[i],&y[i]);
		for(int i=1;i<=n;i++)
			for(int j=i+1;j<=n;j++)
				mp[i][j]=mp[j][i]=sqrt(double(x[i]-x[j])*(x[i]-x[j])+double(y[i]-y[j])*(y[i]-y[j]));
		for(int i=1;i<=n;i++)
			dis[i]=i==1?0:inf;//mp[1][i];
		spfa();
		
		printf("Scenario #%d\nFrog Distance = %.3lf\n\n",t++,dis[2]);
	} 
	
	return 0; 
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章