zoj 1383 Binary Numbers

Binary Numbers

Time Limit: 2 Seconds      Memory Limit: 65536 KB

Given a positive integer n, print out the positions of all 1's in its binary representation. The position of the least significant bit is 0.


Example

The positions of 1's in the binary representation of 13 are 0, 2, 3.


Task

Write a program which for each data set:

reads a positive integer n,

computes the positions of 1's in the binary representation of n,

writes the result.


Input

The first line of the input contains exactly one positive integer d equal to the number of data sets, 1 <= d <= 10. The data sets follow.

Each data set consists of exactly one line containing exactly one integer n, 1 <= n <= 10^6.


Output

The output should consists of exactly d lines, one line for each data set.

Line i, 1 <= i <= d, should contain increasing sequence of integers separated by single spaces - the positions of 1's in the binary representation of the i-th input number.


Sample Input

1
13


Sample Output

0 2 3


分析:

將n轉化爲二進制數,用數組保存。循環一次,將出現1的位置輸出。

代碼:

#include <cstdio>
#include <cstring>

const int MAX_N = 20;

int d, n;
int bit[MAX_N];

void solve() {
    int i, tot = 0;
    memset(bit, 0, sizeof(bit));
    for (i = 0; n != 0; n /= 2) {
        bit[i++] = n % 2;
    }
    for (int j = 0; j < i; j++)
        if (bit[j] == 1)
            tot++;
    for (int j = 0; j < i; j++)
        if (bit[j] == 1) {
            printf("%d", j);
            if (tot > 1)
                printf(" ");
            tot--;
        }
}

int main() {
    scanf("%d", &d);
    for (; d > 0; d--) {
        scanf("%d", &n);
        solve();
        if (d > 1)
            puts("");
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章