POJ 1025(LIS+二分查找)

Description

JGShining's kingdom consists of 2n(n is no more than 500,000) small cities which are located in two parallel lines. 

Half of these cities are rich in resource (we call them rich cities) while the others are short of resource (we call them poor cities). Each poor city is short of exactly one kind of resource and also each rich city is rich in exactly one kind of resource. You may assume no two poor cities are short of one same kind of resource and no two rich cities are rich in one same kind of resource. 

With the development of industry, poor cities wanna import resource from rich ones. The roads existed are so small that they're unable to ensure the heavy trucks, so new roads should be built. The poor cities strongly BS each other, so are the rich ones. Poor cities don't wanna build a road with other poor ones, and rich ones also can't abide sharing an end of road with other rich ones. Because of economic benefit, any rich city will be willing to export resource to any poor one. 

Rich citis marked from 1 to n are located in Line I and poor ones marked from 1 to n are located in Line II. 

The location of Rich City 1 is on the left of all other cities, Rich City 2 is on the left of all other cities excluding Rich City 1, Rich City 3 is on the right of Rich City 1 and Rich City 2 but on the left of all other cities ... And so as the poor ones. 

But as you know, two crossed roads may cause a lot of traffic accident so JGShining has established a law to forbid constructing crossed roads. 

For example, the roads in Figure I are forbidden. 



In order to build as many roads as possible, the young and handsome king of the kingdom - JGShining needs your help, please help him. ^_^ 
 

Input

Each test case will begin with a line containing an integer n(1 ≤ n ≤ 500,000). Then n lines follow. Each line contains two integers p and r which represents that Poor City p needs to import resources from Rich City r. Process to the end of file. 
 

Output

For each test case, output the result in the form of sample. 
You should tell JGShining what's the maximal number of road(s) can be built. 
 

Sample Input

2 1 2 2 1 3 1 2 2 3 3 1
 

Sample Output

Case 1: My king, at most 1 road can be built. Case 2: My king, at most 2 roads can be built.

Hint

 Huge input, scanf is recommended. 
         


題意:

有n個富裕的城市和n個貧窮的城市,要在富裕的城市和貧窮的城市間修建道路,要求兩條路不能交叉,求最大能修多少條路。


思路:

把富裕城市的看成起點,貧窮城市看出終點,用結構體存儲起點和終點,然後按起點從小到大,終點從小到大排序,

然後LIS。這樣,修建城市時只需要判斷起點比它小的城市,終點是否比它大。


具體代碼如下:


#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>

using namespace std;

const int maxn=1e5+100;
int m,dp[maxn],b[maxn];
struct node
{
    int r;
    int p;
} c[maxn];

int cmp(node x,node y)
{
    if(x.r!=y.r)
        return x.r<y.r;
    return x.p<y.p;
}

int main()
{
    int count1=1;
    while(~scanf("%d",&m))
    {
        for(int i=1; i<=m; i++)
        {
            scanf("%d %d",&c[i].r,&c[i].p);
            dp[i]=1;
        }
        sort(c+1,c+m+1,cmp);
        int l,k,mid,maxi=0,len=0;
        for(int i=1; i<=m; i++)
        {
            int num=c[i].p;
            l=1;
            k=len;
            while(l<=k)  // 用二分查找不會超時
            {
                mid=(l+k)>>1;
                if(b[mid]<=num)
                    l=mid+1;
                else
                    k=mid-1;
            }
            b[l]=num;
            dp[i]=l;
            if(l>len)
                len=l;
            if(dp[i]>maxi)
                maxi=dp[i];
        }
        if(maxi>1)  //注意,修建的道路達到兩條的時候rode加上s,我就栽在這上面過。
            printf("Case %d:\nMy king, at most %d roads can be built.\n\n",count1++,maxi);
        else
            printf("Case %d:\nMy king, at most %d road can be built.\n\n",count1++,maxi);
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章