[模擬]uva993 Product of digits



  Product of digits 

For a given non-negative integer number N , find the minimal natural Q such that the product of all digits of Q is equal N .

Input 

The first line of input contains one positive integer number, which is the number of data sets. Each subsequent line contains one data set which consists of one non-negative integer number N (0$ \le$N$ \le$109) .

Output 

For each data set, write one line containing the corresponding natural number Q or `-1' if Q does not exist.

Sample Input 

3 
1 
10 
123456789

Sample Output 

1 
25 
-1




題意:給你一個大於等於0 的整數N,請你你找到最小的自然數Q ,使得在Q 中所有數字(digit)的乘積等於N 。

思路:比較簡單了,就是判斷這個數能否被分解成一串1-9的數字相乘得到。

#include<iostream>
#include<string>

using namespace std;

int main()
{
    int num;
    cin>>num;
    while(num--)
    {
        int n;
        cin>>n;
        if(n==0||n==1)
        {
            cout<<n<<endl;
            continue;
        }
        string str="";
        for(int i=9;i>=2;i--)
        {
            while(n%i==0)
            {
                char ch=('0'+i);
                str=str+ch;
                n=n/i;
            }
        }
        if(n!=1) cout<<"-1"<<endl;
        else
        {
            for(int i=str.size()-1;i>=0;i--)
                cout<<str[i];
            cout<<endl;
        }
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章