F - Tournament(The 2018 ACM-ICPC Asia Qingdao Regional Contest)(找規律+構造)

F - Tournament(The 2018 ACM-ICPC Asia Qingdao Regional Contest)(找規律+構造)

Time limit:1000 ms
Memory limit:65536 kB
judge:
ZOJ - 4063
vjudge

Description

DreamGrid, the king of Gridland, is making a knight tournament. There are nn knights, numbered from 1 to nn, participating in the tournament. The rules of the tournament are listed as follows:

The tournament consists of kk rounds. Each round consists of several duels. Each duel happens between exactly two knights.
Each knight must participate in exactly one duel during each round.
For each pair of knights, there can be at most one duel between them during all the kk rounds.
Let 1i,jk1 \le i, j \le k, iji \ne j, and 1a,b,c,dn1 \le a, b, c, d \le n, a,b,c,da, b, c, d be four distinct integers. If
Knight aa fights against knight bb during round ii, and
Knight cc fights against knight dd during round ii, and
Knight aa fights against knight cc during round jj,
then knight bb must fight against knight dd during round jj.
As DreamGrid’s general, you are asked to write a program to arrange all the duels in all the kk rounds, so that the resulting arrangement satisfies the rules above.

Input

There are multiple test cases. The first line of the input is an integer TT, indicating the number of test cases. For each test case:

The first and only line contains two integers nn and kk (1n,k10001 \le n, k \le 1000), indicating the number of knights participating in the tournament and the number of rounds.

It’s guaranteed that neither the sum of nn nor the sum of kk in all test cases will exceed 5000.

Output

For each test case:

If it’s possible to make a valid arrangement, output kk lines. On the ii-th line, output nn integers ci,1,ci,2,,ci,nc_{i, 1}, c_{i, 2}, \dots, c_{i, n} separated by one space, indicating that in the ii-th round, knight jj will fight against knight ci,jc_{i, j} for all 1jn1 \le j \le n.

If there are multiple valid answers, output the lexicographically smallest answer.

Consider two answers AA and BB, let’s denote ai,ja_{i, j} as the jj-th integer on the ii-th line in answer AA, and bi,jb_{i, j} as the jj-th integer on the ii-th line in answer BB. Answer AA is lexicographically smaller than answer BB, if there exists two integers pp (1pk1 \le p \le k) and qq (1qn1 \le q \le n), such that

for all 1i<p1 \le i < p and 1jn1 \le j \le n, ai,j=bi,ja_{i, j} = b_{i, j}, and
for all 1j<q1 \le j < q, ap,j=bp,ja_{p, j} = b_{p, j}, and finally ap,q<bp,qa_{p, q} < b_{p, q}.
If it’s impossible to make a valid arrangement, output “Impossible” (without quotes) in one line.
Please, DO NOT output extra spaces at the end of each line, or your answer may be considered incorrect!

Sample Input

2
3 1
4 3

Sample Output

Impossible
2 1 4 3
3 4 1 2
4 3 2 1

題意

nn 個騎士要參加 kk 場比賽,每回合他們兩兩對決,對決過的兩個騎士之後不能再次對決。但是這裏有個要求:如果再某回合 AA 對決 BBCC 對決 DD ,那麼當某回合A對決 CDC(D) 時, BB 要對決 DCD(C)

如果能安排比賽,就輸出對決安排,否則就輸出Impossible

注意,輸出的對決安排需要是字典序最小的。

題解

這道題需要找規律。下面給出n爲8的表:

在這裏插入圖片描述
仔細觀察可以發現發生調換的區間寬度剛好是iilowbit(i)2lowbit(i) * 2
在這裏插入圖片描述
而且發現每次調換都是區間內對稱的,這樣就不難寫出代碼了。

而一個 nn 可以構造出的全部的組合是 lowbit(n)1lowbit(n)-1 ,如果所給的 kk 大於這個值,就意味着這麼多的安排是不存在的。

代碼

#include <bits/stdc++.h>
#define maxn 1005
#define _for(i, a) for(int i = 0; i < (a); ++i)
#define _rep(i, a, b) for(int i = (a); i <= (b); ++i)
#define sc(x) scanf("%d", &x)
#define lowerbit(x) (x & (-x))
using namespace std;

int T, n, k, a[maxn];

void sol() {
	if (k > lowerbit(n) - 1) {
		printf("Impossible\n");
		return;
	}
	_rep(i, 1, n) a[i] = i;
	for (int i = 1; i <= k; ++i) {
		int len = lowerbit(i);
		for (int j = 1; j <= n; j += (len << 1)) {
			_for(l, len) {
				swap(a[j + l], a[j + len * 2 - 1 - l]);
			}
		}
		_rep(j, 1, n) printf("%d%s", a[j], j == n ? "\n" : " ");
	}
}

int main() {
	while (cin >> T) {
		_for(i, T) {
			sc(n), sc(k);
			sol();
		}
	}
	return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章