hdoj2602Bone Collector(01揹包裸題)

Problem Description
Many years ago , in Teddy’s hometown there was a man who was called “Bone Collector”. This man like to collect varies of bones , such as dog’s , cow’s , also he went to the grave …
The bone collector had a big bag with a volume of V ,and along his trip of collecting there are a lot of bones , obviously , different bone has different value and different volume, now given the each bone’s value along his trip , can you calculate out the maximum of the total value the bone collector can get ?

 

Input
The first line contain a integer T , the number of cases.
Followed by T cases , each case three lines , the first line contain two integer N , V, (N <= 1000 , V <= 1000 )representing the number of bones and the volume of his bag. And the second line contain N integers representing the value of each bone. The third line contain N integers representing the volume of each bone.
 

Output
One integer per line representing the maximum of the total value (this number will be less than 231).
 

Sample Input
1 5 10 1 2 3 4 5 5 4 3 2 1
 

Sample Output
14
 

#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dp[1010];
int val[1010],cost[1010];
int main()
{
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n,v;
        
        scanf("%d%d",&n,&v);
        int i,j;
        for(i=1;i<=n;i++)
        scanf("%d",&val[i]);
        for(i=1;i<=n;i++)
        scanf("%d",&cost[i]);
        memset(dp,0,sizeof(dp));
        for(i=1;i<=n;i++)
        {
            for(j=v;j>=cost[i];j--)
            {    
            dp[j]=max(dp[j],dp[j-cost[i]]+val[i]);    
            }
        }
        printf("%d\n",dp[v]);
    }
}

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章