1124. Raffle for Weibo Followers (20)

1124. Raffle for Weibo Followers (20)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

John got a full mark on PAT. He was so happy that he decided to hold a raffle(抽獎) for his followers on Weibo -- that is, he would select winners from every N followers who forwarded his post, and give away gifts. Now you are supposed to help him generate the list of winners.

Input Specification:

Each input file contains one test case. For each case, the first line gives three positive integers M (<= 1000), N and S, being the total number of forwards, the skip number of winners, and the index of the first winner (the indices start from 1). Then M lines follow, each gives the nickname (a nonempty string of no more than 20 characters, with no white space or return) of a follower who has forwarded John's post.

Note: it is possible that someone would forward more than once, but no one can win more than once. Hence if the current candidate of a winner has won before, we must skip him/her and consider the next one.

Output Specification:

For each case, print the list of winners in the same order as in the input, each nickname occupies a line. If there is no winner yet, print "Keep going..." instead.

Sample Input 1:
9 3 2
Imgonnawin!
PickMe
PickMeMeMeee
LookHere
Imgonnawin!
TryAgainAgain
TryAgainAgain
Imgonnawin!
TryAgainAgain
Sample Output 1:
PickMe
Imgonnawin!
TryAgainAgain
Sample Input 2:
2 3 5
Imgonnawin!
PickMe
Sample Output 2:
Keep going...
題意:製作一個簡單的微博抽獎系統。輸入m人,起始中獎人是s號(從1 開始計數),下一個中獎人爲s+n號,直到s+n>m

思路:思路很簡單上面已經說了。我選擇vector<string>存儲,用字符數組也沒問題。但是,用vector<string>有一個特別坑的地方,它的 num.size(),返回的不是int,而是無符號整數(unsigned int),所以不能直接和int做 > < 比較。

代碼:

#include<iostream>
#include<string>
#include<vector>
using namespace std;
int main()
{
	int m, n, s, i, j;
	cin >> m >> n >> s;
	vector<string> people;
	vector<string> winner;
	string tmp;
	for (int i = 0; i < m; i++)
	{
		cin >> tmp;
		people.push_back(tmp);
	}
	s--;//模擬從1開始計數
	if (s >= m) {
		cout << "Keep going..." << endl;
		return 0;
	}
	else {
		while (s < m)
		{
			int size = winner.size();//將unsigned int 轉化爲 int
			for (i = 0; i < size; i++)
				if (winner[i] == people[s]) break;
			if (i != size) 	s++;
			else {
				cout << people[s] << endl;
				winner.push_back(people[s]);
				s += n;
			}
		}
	}
	return 0;
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章