1125. Chain the Ropes (25)

1125. Chain the Ropes (25)

時間限制
200 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Given some segments of rope, you are supposed to chain them into one rope. Each time you may only fold two segments into loops and chain them into one piece, as shown by the figure. The resulting chain will be treated as another segment of rope and can be folded again. After each chaining, the lengths of the original two segments will be halved.

Your job is to make the longest possible rope out of N given segments.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (2 <= N <= 104). Then N positive integer lengths of the segments are given in the next line, separated by spaces. All the integers are no more than 104.

Output Specification:

For each case, print in a line the length of the longest possible rope that can be made by the given segments. The result must be rounded to the nearest integer that is no greater than the maximum length.

Sample Input:
8
10 15 12 3 4 13 1 15
Sample Output:
14
題意:給出N段繩子,每次你可以任意選兩端進行合併,合併後的繩子去對摺的長度加入集合,重複操作直至只有一條。要求輸出最長的一種情況。

思路:很明顯想要最長的,得要讓小的先進入合併,大的放最後,所以開始時我選擇了qsort(),然而測試點掛了一片……

           冥思苦想下發現,併入的節點可能比排序後數組最小的那一個要大,但是顯然不能每次都排序(其實因爲有序,用二分查找也是可以的)

           這時候當然選擇我們的排序利器,set啦!

           因爲有重複的數值,所以聲明用multiset

           同樣因爲有重複的數值,erase(a),這種是不可取的,它會把一次把所有相同的元素都刪除

           set begin(),返回的是迭代器,所以用 * 返回迭代器所指的元素

代碼:

#include<iostream>
#include<algorithm>
#include<set>
using namespace std;
int main()
{
	int n, tmp;
	cin >> n;
	multiset<int> num;
	for (int i = 0; i < n; i++)
	{
		cin >> tmp;
		num.insert(tmp);
	}
	while (num.size() >= 2)
	{
		int a = *num.begin(); num.erase(num.begin());
		int b = *num.begin(); num.erase(num.begin());
		num.insert((a + b) / 2);
	}
	cout << *num.begin() << endl;
}





發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章