1129. Recommendation System (25)

1129. Recommendation System (25)

時間限制
400 ms
內存限制
65536 kB
代碼長度限制
16000 B
判題程序
Standard
作者
CHEN, Yue

Recommendation system predicts the preference that a user would give to an item. Now you are asked to program a very simple recommendation system that rates the user's preference by the number of times that an item has been accessed by this user.

Input Specification:

Each input file contains one test case. For each test case, the first line contains two positive integers: N (<= 50000), the total number of queries, and K (<= 10), the maximum number of recommendations the system must show to the user. Then given in the second line are the indices of items that the user is accessing -- for the sake of simplicity, all the items are indexed from 1 to N. All the numbers in a line are separated by a space.

Output Specification:

For each case, process the queries one by one. Output the recommendations for each query in a line in the format:

query: rec[1] rec[2] ... rec[K]

where query is the item that the user is accessing, and rec[i] (i = 1, ... K) is the i-th item that the system recommends to the user. The first K items that have been accessed most frequently are supposed to be recommended in non-increasing order of their frequencies. If there is a tie, the items will be ordered by their indices in increasing order.

Note: there is no output for the first item since it is impossible to give any recommendation at the time. It is guaranteed to have the output for at least one query.

Sample Input:
12 3
3 5 7 5 5 3 2 1 8 3 8 12
Sample Output:
5: 3
7: 3 5
5: 3 5 7
5: 5 3 7
3: 5 3 7
2: 5 3 7
1: 5 3 2
8: 5 3 1
3: 5 3 1
8: 3 5 1
12: 3 5 8

題意:做一個簡單的推薦系統。用戶輸入N個查詢,對於每個查詢,輸出K的推薦。

推薦的規則:按查詢次數由大到小輸出,相等時,優先輸出 數值 小的(即 3 5 次數相等時,先輸出3再輸出5)

思路:利用set自動排序的功能存儲,由於需要記錄兩個參數(數值 和 次數),所以要重載<,以便排序

    由於排序時 需要用到插入、查找的操作,所以在struct 結構體內需要一個構造函數,便於插入、查找。

代碼:

#include<iostream>
#include<set>
using namespace std;
struct node {
	int value;
	int cnt;
	node(int a, int b) :value(a), cnt(b) {}
	bool operator < (const node & a) const {
		return (cnt != a.cnt) ? cnt > a.cnt :value < a.value;
	}
};
int times[50010] = { 0 };
int main()
{
	int n, k, tmp;
	cin >> n >> k;
	set<node > num;
	for (int i = 0; i < n; i++)
	{
		cin >> tmp;
		if (i)
		{
			cout << tmp << ":";
			int j = 0;
			for (auto t = num.begin(); j < k && t != num.end(); t++, j++)
				cout << " " << t->value;
			cout << endl;
		}
		auto t = num.find(node(tmp, times[tmp]));
		if (t != num.end()) num.erase(t);
		times[tmp]++;
		num.insert(node(tmp, times[tmp]));
	}
}


結尾: 這題做的很有挫敗感。先是題目半天讀不懂,百度了以後發現排序很繁瑣,再次百度以後知道了要用set,然後先前沒有接觸於是又是一通百度,實現的過程也是慘不忍睹……最後還是藉助了柳婼小姐姐的代碼  http://blog.csdn.net/liuchuo/article/details/68912867 




發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章