hdoj 5344 MZL's xor (簡單異或)

MZL's xor

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 1264    Accepted Submission(s): 784


Problem Description
MZL loves xor very much.Now he gets an array A.The length of A is n.He wants to know the xor of all (Ai+Aj)(1i,jn)
The xor of an array B is defined as B1 xor B2...xor Bn
 

Input
Multiple test cases, the first line contains an integer T(no more than 20), indicating the number of cases.
Each test case contains four integers:n,m,z,l
A1=0,Ai=(Ai1m+z) mod l
1m,z,l5105,n=5105
 

Output
For every test.print the answer.
 

Sample Input
2 3 5 5 7 6 8 8 9
 

Sample Output
14 16
題意:所有(Ai+Aj)(1i,jnn)的異或值,最後只剩下2*a[i]的異或

code

#include <iostream>
#include<cstdio>
using namespace std;
#define MAXN 500010
#define LL long long
LL a[MAXN];
int main()
{
    int t,m,n,z,l;
    scanf("%d",&t);
    while(t--)
    {
        scanf("%d%d%d%d",&n,&m,&z,&l);
        a[1]=0;
        for(int i=2;i<=n;i++)
        {
            a[i]=(a[i-1]*m+z)%l;
        }
        long long ans=0;
        for(int i=1;i<=n;i++)
        {
            ans=ans^(2*a[i]);
        }
        printf("%lld\n",ans);
    }

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章