hdoj 1433 Simply Syntax【模擬】

Simply Syntax

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 416    Accepted Submission(s): 208


Problem Description
In the land of Hedonia the official language is Hedonian. A Hedonian professor had noticed that many of her students still did not master the syntax of Hedonian well. Tired of correcting the many syntactical mistakes, she decided to challenge the students and asked them to write a program that could check the syntactical correctness of any sentence they wrote. Similar to the nature of Hedonians, the syntax of Hedonian is also pleasantly simple. Here are the rules: 

0. The only characters in the language are the characters p through z and N, C, D, E, and I. 

1. Every character from p through z is a correct sentence. 

2. If s is a correct sentence, then so is Ns. 

3. If s and t are correct sentences, then so are Cst, Dst, Est and Ist. 

4. Rules 0. to 3. are the only rules to determine the syntactical correctness of a sentence. 

You are asked to write a program that checks if sentences satisfy the syntax rules given in Rule 0. - Rule 4. 
 

Input
The input consists of a number of sentences consisting only of characters p through z and N, C, D, E, and I. Each sentence is ended by a new-line character. The collection of sentences is terminated by the end-of-file character. If necessary, you may assume that each sentence has at most 256 characters and at least 1 character.
 

Output
The output consists of the answers YES for each well-formed sentence and NO for each not-well-formed sentence. The answers are given in the same order as the sentences. Each answer is followed by a new-line character, and the list of answers is followed by an end-of-file character. 

 

Sample Input
Cp Isz NIsz Cqpq
 

Sample Output
NO YES YES NO
 

Source
 

Recommend
lcy
 

Statistic | Submit | Discuss | Note


//就是統計這個字符串中有多少個句子,如果只有一個就輸出YES,否則輸出NO! 
#include <stdio.h>
#include <string.h>
#include <algorithm>
using namespace std;
char a[256+10];
int main()
{
	while(scanf("%s",a)!=EOF)
	{
		int cou=0,len=strlen(a);
		for(int i=len-1;i>=0;i--)
		{
			if(a[i]>='p'&&a[i]<='z')
				cou++;
			else if(a[i]=='N')
			{
				if(cou==0)
				{
					break;
				}
			}
			else if(a[i]=='C'||a[i]=='D'||a[i]=='E'||a[i]=='I')
			{
				if(cou>=2)
				{
					cou--;
				}
				else
				{
					cou=0;break;
				}
			}
			else
			{
				cou=0;break;
			}
		}
		if(cou==1)
			printf("YES\n");
		else
			printf("NO\n");
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章