Stars--HDU1541(二维偏序-树状数组)

Stars

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)

题目链接http://acm.hdu.edu.cn/showproblem.php?pid=1541

Problem Description

Astronomers often examine star maps where stars are represented by points on a plane and each star has Cartesian coordinates. Let the level of a star be an amount of the stars that are not higher and not to the right of the given star. Astronomers want to know the distribution of the levels of the stars. 



For example, look at the map shown on the figure above. Level of the star number 5 is equal to 3 (it's formed by three stars with a numbers 1, 2 and 4). And the levels of the stars numbered by 2 and 4 are 1. At this map there are only one star of the level 0, two stars of the level 1, one star of the level 2, and one star of the level 3. 

You are to write a program that will count the amounts of the stars of each level on a given map.

 

Input

The first line of the input file contains a number of stars N (1<=N<=15000). The following N lines describe coordinates of stars (two integers X and Y per line separated by a space, 0<=X,Y<=32000). There can be only one star at one point of the plane. Stars are listed in ascending order of Y coordinate. Stars with equal Y coordinates are listed in ascending order of X coordinate.

 

 

Output

The output should contain N lines, one number per line. The first line contains amount of stars of the level 0, the second does amount of stars of the level 1 and so on, the last line contains amount of stars of the level N-1.

 

Sample Input

5

1 1

5 1

7 1

3 3

5 5

Sample Output

1

2

1

1

0


题目大意:定义星星的级别是在它左边或下边的星星的数量,求0到N-1级别的星星的数量,给出n个星星,n行,x,y

我们可以直接先将x轴固定,然后对接下来的y在1到n-1中找比他矮的就行了。。。那么线段树或者树状数组就可以很棒地解决这个问题了

有两个坑点注意,y可能为0,那么树状数组的lowbit(0)=0,add函数就会T掉,所以我们对每个y加上1,第二个就是要多组,没有多组会WA。。。。

以下是AC代码:

#include <bits/stdc++.h>
using namespace std;

const int mac=1.5e4+10;
const int maxn=3.2e4+10;

int lowbit(int x)
{
    return x&-x;
}

struct node
{
    int x,y;
}a[mac];

int n,c[32050],level[mac];

int query(int pos)
{
    int ans=0;
    while (pos>0){
        ans+=c[pos];
        pos-=lowbit(pos);
    }
    return ans;
}

void add(int pos)
{
    while (pos<=maxn){
        c[pos]+=1;
        pos+=lowbit(pos);
    }
}

bool cmp(node a,node b)
{
    if (a.x==b.x) return a.y<b.y;
    return a.x<b.x;
}

int main()
{
    while (scanf ("%d",&n)!=EOF){
        for (int i=1; i<=n; i++){
            int x,y;
            scanf ("%d%d",&x,&y);
            a[i].x=x,a[i].y=y;
        }
        sort(a+1,a+1+n,cmp);
        memset(level,0,sizeof level);
        memset(c,0,sizeof c);
        for (int i=1; i<=n; i++){
            int nb=query(a[i].y+1);
            level[nb]++;
            add(a[i].y+1);
        }
        for (int i=0; i<n; i++){
            printf ("%d\n",level[i]);
        }
    }
    return 0;
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章