1132 Cut Integer (20分) &&的特性

1132 Cut Integer (20分)

Cutting an integer means to cut a K digits lone integer Z into two integers of (K/2) digits long integers A and B. For example, after cutting Z = 167334, we have A = 167 and B = 334. It is interesting to see that Z can be devided by the product of A and B, as 167334 / (167 × 334) = 3. Given an integer Z, you are supposed to test if it is such an integer.

Input Specification:

Each input file contains one test case. For each case, the first line gives a positive integer N (≤ 20). Then N lines follow, each gives an integer Z (10 ≤ Z <2​31​​). It is guaranteed that the number of digits of Z is an even number.

Output Specification:

For each case, print a single line Yes if it is such a number, or No if not.

Sample Input:

3
167334
2333
12345678

Sample Output:

Yes
No
No

很簡單一道題

但是我錯在了細節

之前所有錯的,全是因爲if括號內n的位置,先進行d%n==0   n有可能爲0 報浮點錯誤

如果把n放在&&前,就不會了,

跟&&的特點有關。

A&&B 如果A是false,他就不會在乎B是啥了

細節決定成敗!

#include<iostream>
using namespace std;
int count(int d){
	int c=0;
	while(d){
		c++;
		d/=10;
	}
	return c;
}
int main(){
	int n,t,d;
	int  i,j,k,m;
	cin>>m;
	while(m--){
		cin>>d;
		k=count(d);
		j=1;
        k/=2;
		for(i=0;i<k;i++){
			j*=10;
		}
		n=(d/j)*(d%j);
		if(n&&d%n==0)
		cout<<"Yes"<<endl;
		else
		cout<<"No"<<endl;
	}
}

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章