1128 N Queens Puzzle (20分) N皇后 問題

1128 N Queens Puzzle (20分)

The "eight queens puzzle" is the problem of placing eight chess queens on an 8×8 chessboard so that no two queens threaten each other. Thus, a solution requires that no two queens share the same row, column, or diagonal. The eight queens puzzle is an example of the more general N queens problem of placing N non-attacking queens on an N×N chessboard. (From Wikipedia - "Eight queens puzzle".)

Here you are NOT asked to solve the puzzles. Instead, you are supposed to judge whether or not a given configuration of the chessboard is a solution. To simplify the representation of a chessboard, let us assume that no two queens will be placed in the same column. Then a configuration can be represented by a simple integer sequence (Q​1​​,Q​2​​,⋯,Q​N​​), where Q​i​​ is the row number of the queen in the i-th column. For example, Figure 1 can be represented by (4, 6, 8, 2, 7, 1, 3, 5) and it is indeed a solution to the 8 queens puzzle; while Figure 2 can be represented by (4, 6, 7, 2, 8, 1, 9, 5, 3) and is NOT a 9 queens' solution.

8q.jpg   9q.jpg
Figure 1   Figure 2

Input Specification:

Each input file contains several test cases. The first line gives an integer K (1<K≤200). Then K lines follow, each gives a configuration in the format "N Q​1​​ Q​2​​ ... Q​N​​", where 4≤N≤1000 and it is guaranteed that 1≤Q​i​​≤N for all i=1,⋯,N. The numbers are separated by spaces.

Output Specification:

For each configuration, if it is a solution to the N queens problem, print YES in a line; or NO if not.

Sample Input:

4
8 4 6 8 2 7 1 3 5
9 4 6 7 2 8 1 9 5 3
6 1 5 2 6 4 3
5 1 3 5 2 4

Sample Output:

YES
NO
NO
YES

關鍵是判斷同行、同列、同一對角線上有沒有皇后,

如何判斷?

聲明一個數組,舉個例子 ,a[i]=j    表示第i 行第j列有皇后

對角線就是abs(v[j]-v[i])==abs(j-i)  同一列就是v[i]==v[j]

#include<iostream>
#include<algorithm>
#include<cstdio>
using namespace std;
#define range 1002
int chess[range];
bool check(int id){
	for(int i=1;i<id;i++){
		if(chess[i]==chess[id]||chess[i]-chess[id]==i-id||chess[i]-chess[id]==id-i){
			return false;
		}
	}
	return true;
}
int main(){
	int n,i,j,t,d;
	scanf("%d",&n);
	while(n--){
		int f=0;
		scanf("%d",&t);
		fill(chess,chess+t,0);
		for(i=1;i<=t;i++){
			scanf("%d",&chess[i]);
		}
		for(i=1;i<=t;i++){
			if(!check(i)){
				f=1;
				break;
			}
		}
		if(f!=1){
			printf("YES\n");
		}
		else{
			printf("NO\n");
		}
	}
	return 0;
}

 

 

 

 

 

 

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章