HDU 5745 La Vie en rose(DP,枚举)

Problem Description
Professor Zhang would like to solve the multiple pattern matching problem, but he only has only one pattern string p=p1p2...pm. So, he wants to generate as many as possible pattern strings from p using the following method:

1. select some indices i1,i2,...,ik such that 1i1<i2<...<ik<|p| and |ijij+1|>1 for all 1j<k.
2. swap pij and pij+1 for all 1jk.

Now, for a given a string s=s1s2...sn, Professor Zhang wants to find all occurrences of all the generated patterns in s.
 

Input
There are multiple test cases. The first line of input contains an integer T, indicating the number of test cases. For each test case:

The first line contains two integers n and m (1n105,1mmin{5000,n}) -- the length of s and p.

The second line contains the string s and the third line contains the string p. Both the strings consist of only lowercase English letters.
 

Output
For each test case, output a binary string of length n. The i-th character is "1" if and only if the substring sisi+1...si+m1 is one of the generated patterns.
 

Sample Input
3 4 1 abac a 4 2 aaaa aa 9 3 abcbacacb abc
 

Sample Output
1010 1110 100100100
 


题意:给定一个长度为n的匹配串s和长度为m的模式串p,p可以进行变换,变换规则是任意交换两个相邻的字符,但是每个字符最多(被)交换一次。结果输出一个n位的二进制,对于匹配串的字符位置i,如果s的子串(si,si+1,si+2,...,si+m-1)可以由p串变换得出的话,则这个位置输出“1”,否则输出“0”


因为每个字符最多交换或者被交换一次,那么所有交换都是互不影响的,判断p是不是可以构造成目标串,只需O(m)地遍历一遍p串和对应位置的s串,遇到不可交换且不匹配就退出并输出0,否则全部匹配就输出1,然后O(n)地枚举s的所有子串,即可在O(nm)时间得出答案(显然i>n - m就直接输出0),严格上说这不算DP,但题解上说这是O(nm)的DP,所以也就是运用了一些dp的简单思想而已,代码如下:


#include <bits/stdc++.h>

using namespace std;

char s[100010];
char p[10010];

int main()
{
	int t,n,m;
	scanf("%d",&t);
	while(t--)
	{
		scanf("%d %d",&n,&m);
		scanf("%s %s",s,p);
		for(int i = 0 ; i < n ; i++)
		{
			if(i > n - m)
			{
				putchar('0');
				continue;
			}
			bool f = true;
			for(int j = 0 ; j < m ; j++)
			{
				if(j < m - 1 && p[j] == s[i + j + 1] && p[j + 1] == s[i + j])
					j++;
				else if(p[j] != s[i + j])
				{
					f = false;
					break;
				}
			}
			putchar(f ? '1' : '0');
		}
		puts("");
	}

    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章