概率dp Discovering Gold

Discovering Gold
You are in a cave, a long cave! The cave can be represented by a 1 x N grid. Each cell of the cave can contain any amount of gold.

Initially you are in position 1. Now each turn you throw a perfect 6 sided dice. If you get X in the dice after throwing, you add X to your position and collect all the gold from the new position. If your new position is outside the cave, then you keep throwing again until you get a suitable result. When you reach the Nth position you stop your journey. Now you are given the information about the cave, you have to find out the expected number of gold you can collect using the given procedure.

Input

Input starts with an integer T (≤ 100), denoting the number of test cases.

Each case contains a blank line and an integer N (1 ≤ N ≤ 100) denoting the dimension of the cave. The next line contains N space separated integers. The ith integer of this line denotes the amount of gold you will get if you come to the ith cell. You may safely assume that all the given integers will be non-negative and no integer will be greater than 1000.

Output

For each case, print the case number and the expected number of gold you will collect. Errors less than 10-6 will be ignored.

Sample Input
3
1
101
2
10 3
3
3 6 9
Sample Output
Case 1: 101.0000000000
Case 2: 13.000
Case 3: 15

最後期望就是到達每點的概率*每點的值,如果是最後幾個點,比如倒數第4個點,他後面只有三個點,改點到達後面點的概率是1/3

#include<bits/stdc++.h>
#include<stdio.h>
#include<algorithm>
#include<ctype.h>
using namespace std;
#define Init(a,v) memset(a,v,sizeof(a))
#define Tie ios::sync_with_stdio(0);cin.tie(0)
typedef long long ll;
const ll MAXN=1e1+8,inf=0x3f3f3f3f,mod=1e9+7;
int a[MAXN];
double p[MAXN],ans;
int main() {
    freopen("in","r",stdin);
    Tie;
    int t,cas=1;
    cin>>t;
    while(t--){
        int n;
        cin>>n;
        for(int i=1;i<=n;++i)cin>>a[i];
        p[1]=1;
        for(int i=2;i<=n;++i)p[i]=0;
        ans=0;
        for(int i=1;i<=n;++i){
            int k=min(6,n-i);
            for(int j=i+1;j<=n&&j<=i+6;++j){
                p[j]+=p[i]/k;//j點可以由i點到達。
            }
            ans+=p[i]*a[i];
        }
        printf("Case %d: %lf\n",cas++,ans);
    }
    return 0;
}
發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章