POJ--3615|Cow Hurdles

Cow Hurdles
Time Limit: 1000MS   Memory Limit: 65536K
Total Submissions: 7699   Accepted: 3460

Description

Farmer John wants the cows to prepare for the county jumping competition, so Bessie and the gang are practicing jumping over hurdles. They are getting tired, though, so they want to be able to use as little energy as possible to jump over the hurdles.

Obviously, it is not very difficult for a cow to jump over several very short hurdles, but one tall hurdle can be very stressful. Thus, the cows are only concerned about the height of the tallest hurdle they have to jump over.

The cows' practice room has N (1 ≤ N ≤ 300) stations, conveniently labeled 1..N. A set of M (1 ≤ M ≤ 25,000) one-way paths connects pairs of stations; the paths are also conveniently labeled 1..M. Path i travels from station Si to station Ei and contains exactly one hurdle of height Hi (1 ≤ Hi ≤ 1,000,000). Cows must jump hurdles in any path they traverse.

The cows have T (1 ≤ T ≤ 40,000) tasks to complete. Task i comprises two distinct numbers, Ai and Bi (1 ≤ Ai ≤ N; 1 ≤ Bi ≤ N), which connote that a cow has to travel from station Ai to station Bi (by traversing over one or more paths over some route). The cows want to take a path the minimizes the height of the tallest hurdle they jump over when traveling from Ai to Bi . Your job is to write a program that determines the path whose tallest hurdle is smallest and report that height.
 

Input

* Line 1: Three space-separated integers: NM, and T
* Lines 2..M+1: Line i+1 contains three space-separated integers: Si , Ei , and Hi 
* Lines M+2..M+T+1: Line i+M+1 contains two space-separated integers that describe task i: Ai and Bi

Output

* Lines 1..T: Line i contains the result for task i and tells the smallest possible maximum height necessary to travel between the stations. Output -1 if it is impossible to travel between the two stations.

Sample Input

5 6 3
1 2 12
3 2 8
1 3 5
2 5 3
3 4 4
2 4 8
3 4
1 2
5 1

Sample Output

4
8
-1

Source




Floyd的變型題,讀懂題意即可AC。

關鍵字已用紅字標註!!!


/*
name:Rollchuchy
type:
*/
#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
using namespace std;
int dis[305][305];
struct node{
	int a,b;
}T[40005];
const int INF=1e9+7;
void clear()
{
	memset(T,0,sizeof(T));
	for(int i=0;i<=300;i++){
		for(int j=0;j<=300;j++){
			dis[i][j]=INF;
		}
	}
	for(int i=0;i<=300;i++){
		dis[i][i]=0;
	}
}
int main()
{
	//freopen("in.txt","r",stdin);
	int n,m,t;
	while(~scanf("%d %d %d",&n,&m,&t)){
		clear();
		int s,e,h;
		for(int i=0;i<m;i++){
			scanf("%d %d %d",&s,&e,&h);
			if(h<dis[s][e]){
				dis[s][e]=h;
			}
		}
		for(int i=0;i<t;i++)
		{
			scanf("%d %d",&T[i].a,&T[i].b);
		}
		for(int k=1;k<=n;k++){
			for(int i=1;i<=n;i++){
				for(int j=1;j<=n;j++){
					dis[i][j]=min(dis[i][j],max(dis[i][k],dis[k][j]));
				}
			}
		}
		for(int i=0;i<t;i++){
			printf("%d\n",dis[T[i].a][T[i].b]==INF?-1:dis[T[i].a][T[i].b]);
		}
	}
	return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章