What Are You Talking About(map)

What Are You Talking About

Time Limit: 10000/5000 MS (Java/Others)    Memory Limit: 102400/204800 K (Java/Others)
Total Submission(s): 28122    Accepted Submission(s): 9595


 

Problem Description

Ignatius is so lucky that he met a Martian yesterday. But he didn't know the language the Martians use. The Martian gives him a history book of Mars and a dictionary when it leaves. Now Ignatius want to translate the history book into English. Can you help him?

 

 

Input

The problem has only one test case, the test case consists of two parts, the dictionary part and the book part. The dictionary part starts with a single line contains a string "START", this string should be ignored, then some lines follow, each line contains two strings, the first one is a word in English, the second one is the corresponding word in Martian's language. A line with a single string "END" indicates the end of the directory part, and this string should be ignored. The book part starts with a single line contains a string "START", this string should be ignored, then an article written in Martian's language. You should translate the article into English with the dictionary. If you find the word in the dictionary you should translate it and write the new word into your translation, if you can't find the word in the dictionary you do not have to translate it, and just copy the old word to your translation. Space(' '), tab('\t'), enter('\n') and all the punctuation should not be translated. A line with a single string "END" indicates the end of the book part, and that's also the end of the input. All the words are in the lowercase, and each word will contain at most 10 characters, and each line will contain at most 3000 characters.

 

 

Output

In this problem, you have to output the translation of the history book.

 

 

Sample Input


 

START from fiwo hello difh mars riwosf earth fnnvk like fiiwj END START difh, i'm fiwo riwosf. i fiiwj fnnvk! END

 

 

Sample Output


 

hello, i'm from mars. i like earth!

AC代碼:

#include<cstdio>
#include<iostream>
#include<string>
#include<string.h>
#include<map>
using namespace std;
int main()
{ 
	map<string,string> dic;
	string a,b;
	cin>>a;
	while(cin>>a&&a!="END")
	{
		cin>>b;dic[b]=a;
	}
	cin>>a;getchar();char c[2000];
	while(1)
	{
		int i;
		gets(c);if(strcmp(c,"END")==0) break;
		int len=strlen(c);b="";
		for(i=0;i<len;i++)
		{
			if(c[i]>='a'&&c[i]<='z')
			b+=c[i];
			else
			{
				if(dic[b]!="") cout<<dic[b];
				else cout<<b;
				b="";
				cout<<c[i];
			}
		}
		printf("\n");
	}
}

 

發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章