pku3261 Milk Patterns 後綴數組/可重疊的 k 次最長重複子串

Milk Patterns
Time Limit: 5000MS   Memory Limit: 65536K
Total Submissions: 16696   Accepted: 7371
Case Time Limit: 2000MS

Description

Farmer John has noticed that the quality of milk given by his cows varies from day to day. On further investigation, he discovered that although he can't predict the quality of milk from one day to the next, there are some regular patterns in the daily milk quality.

To perform a rigorous study, he has invented a complex classification scheme by which each milk sample is recorded as an integer between 0 and 1,000,000 inclusive, and has recorded data from a single cow over N (1 ≤ N ≤ 20,000) days. He wishes to find the longest pattern of samples which repeats identically at least K (2 ≤ K ≤ N) times. This may include overlapping patterns -- 1 2 3 2 3 2 3 1 repeats 2 3 2 3 twice, for example.

Help Farmer John by finding the longest repeating subsequence in the sequence of samples. It is guaranteed that at least one subsequence is repeated at least K times.

Input

Line 1: Two space-separated integers: N and K 
Lines 2..N+1: N integers, one per line, the quality of the milk on day i appears on the ith line.

Output

Line 1: One integer, the length of the longest pattern which occurs at least K times

Sample Input

8 2
1
2
3
2
3
2
3
1

Sample Output

4

Source



先二分答案,然後將後綴分成若干組。不
同的是,這裏要判斷的是有沒有一個組的後綴個數不小於 k。如果有,那麼存在
k 個相同的子串滿足條件,否則不存在



//#include<bits/stdc++.h>
#include<iostream>
#include<cstdio>
#include<cstring>
#include<cstdlib>
#include<set>
#include<ctime>
#include<vector>
#include<cmath>
#include<algorithm>


using namespace std;
typedef long long ll;
const int MAXN = 20005;
/*
*suffix array
*倍增算法  O(n*logn)
*待排序數組長度爲n,放在0~n-1中,在最後面補一個0
*build_sa( ,n+1, );//注意是n+1;
*getHeight(,n);
*例如:
*n   = 8;
*num[]   = { 1, 1, 2, 1, 1, 1, 1, 2, $ };注意num最後一位爲0,其他大於0
*rank[]  = { 4, 6, 8, 1, 2, 3, 5, 7, 0 };rank[0~n-1]爲有效值,rank[n]必定爲0無效值
*sa[]    = { 8, 3, 4, 5, 0, 6, 1, 7, 2 };sa[1~n]爲有效值,sa[0]必定爲n是無效值
*height[]= { 0, 0, 3, 2, 3, 1, 2, 0, 1 };height[2~n]爲有效值
*
*/

int sa[MAXN];//SA數組,表示將S的n個後綴從小到大排序後把排好序的
             //的後綴的開頭位置順次放入SA中
int t1[MAXN],t2[MAXN],c[MAXN];//求SA數組需要的中間變量,不需要賦值
int rank1[MAXN],height[MAXN];
//待排序的字符串放在s數組中,從s[0]到s[n-1],長度爲n,且最大值小於m,
//除s[n-1]外的所有s[i]都大於0,r[n-1]=0
//函數結束以後結果放在sa數組中
void build_sa(int s[],int n,int m)
{
    int i,j,p,*x=t1,*y=t2;
    //第一輪基數排序,如果s的最大值很大,可改爲快速排序
    for(i=0;i<m;i++)c[i]=0;
    for(i=0;i<n;i++)c[x[i]=s[i]]++;
    for(i=1;i<m;i++)c[i]+=c[i-1];
    for(i=n-1;i>=0;i--)sa[--c[x[i]]]=i;
    for(j=1;j<=n;j<<=1)
    {
        p=0;
        //直接利用sa數組排序第二關鍵字
        for(i=n-j;i<n;i++)y[p++]=i;//後面的j個數第二關鍵字爲空的最小
        for(i=0;i<n;i++)if(sa[i]>=j)y[p++]=sa[i]-j;
        //這樣數組y保存的就是按照第二關鍵字排序的結果
        //基數排序第一關鍵字
        for(i=0;i<m;i++)c[i]=0;
        for(i=0;i<n;i++)c[x[y[i]]]++;
        for(i=1;i<m;i++)c[i]+=c[i-1];
        for(i=n-1;i>=0;i--)sa[--c[x[y[i]]]]=y[i];
        //根據sa和x數組計算新的x數組
        swap(x,y);
        p=1;x[sa[0]]=0;
        for(i=1;i<n;i++)
            x[sa[i]]=y[sa[i-1]]==y[sa[i]] && y[sa[i-1]+j]==y[sa[i]+j]?p-1:p++;
        if(p>=n)break;
        m=p;//下次基數排序的最大值
    }
}
void getHeight(int s[],int n)
{
    int i,j,k=0;
    for(i=0;i<=n;i++)rank1[sa[i]]=i;
    for(i=0;i<n;i++)
    {
        if(k)k--;
        j=sa[rank1[i]-1];
        while(s[i+k]==s[j+k])k++;
        height[rank1[i]]=k;
    }
}

int str[MAXN];
int s[MAXN];
int n,k;
bool check(int len)
{
    int l,r;
    l = 2,r=2;
    while(l<=n&&r<=n)
    {
        if(height[l]<len)
        {
            l++;
            continue;
        }
        if(height[l]>=len)
        {
            r=l;
            while(height[r]>=len && r<=n) r++;
        }
        if(r-l+1>=k)
        {
            return true;
        }
        l=r;
    }
//    cout <<"len : "<<len<<endl;
    return false;
}

int main()
{
//    freopen("data.txt","r",stdin);
    while(scanf("%d %d",&n,&k)==2)
    {
        for(int i=0;i<n;i++)
            scanf("%d",&s[i]);
        s[n]=0;

        build_sa(s,n+1,250);
        getHeight(s,n);




        int ans=0;
        int l = 1;
        int r = n;
        while(l<=r)
        {
            int mid=(l+r)>>1;
            if(check(mid))
                ans=mid,l=mid+1;
            else
                r=mid-1;
        }
        printf("%d\n",ans);
    }
    return 0;
}










發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章