ACM刷題之ZOJ————Break Standard Weight

Break Standard Weight

Time Limit: 2 Seconds      Memory Limit: 65536 KB

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 145 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are x and y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4 and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ xy ≤ 100

Output

For each test case, output the maximum number of possible special masses.

Sample Input

2
4 9
10 10

Sample Output

13
9


水題
暴力枚舉,用 set來存儲去重

下面是ac代碼
#include<stdio.h>
#include<string.h>
#include<stdlib.h>
#include<math.h>
#include<algorithm>
#include<map>
#include<set>
#include<queue>
#include<string>
#include<iostream>
using namespace std;
#define MID(x,y) ((x+y)>>1)
#define CLR(arr,val) memset(arr,val,sizeof(arr))
#define FAST_IO ios::sync_with_stdio(false);cin.tie(0);
const double PI = acos(-1.0);
const int INF = 0x3f3f3f3f;
const int N=2e5+7;
int maxx;
set<int>s;
set<int>::iterator it1;

void finds(int a,int b,int c)
{

	s.insert(a+b+c);
	s.insert(b-a+c);
	
	
	
	if(c>a-b)
		s.insert(c-(a-b));
	
	if(c>(b-a))
		s.insert(c-(b-a));
		
	if(a>(c-b))
		s.insert(a-(c-b));
	
	if(a>(b-c))
		s.insert(a-(b-c));
		
	if(b>(c-a))
		s.insert(b-(c-a));
	
	if(b>(a-c))
		s.insert(b-(a-c));
		
	
	
	
	if(c>b)
	{
		s.insert(c-b);
		s.insert(c-a);
		if(c>a+b)
		{
			s.insert(c-a-b);
		}
	}
	
	if(c>a){
		s.insert(c-a);
	}
	
	if(c<b){
		s.insert(b-c);
		if(b>a+c){
			s.insert(b-a-c);
		}
		
	}
	
	if(c<a){
		s.insert(a-c);
	}
	
	
	
	
	s.insert(a+b);
	s.insert(a+c);
	s.insert(c+b);
	
	if(b!=a)
	s.insert(b-a);
	
	s.insert(a);
	s.insert(b);
	s.insert(c);
	
	if(s.size()>maxx)
		maxx=s.size();
/*	
	for(it1=s.begin();it1!=s.end();it1++)
	{
		cout<<*it1<<endl;
	}
	printf("\n"); */
	
}


int main()
{
	//freopen("f:/input.txt", "r", stdin);
	int zu,i,j,k,n,m,x;
	scanf("%d",&zu);
	while(zu--)
	{
		maxx=0;
		
		scanf("%d%d",&n,&m);
		x=n/2;
		for(i=1;i<=x;i++)
		{
			s.clear();
			finds(i,n-i,m);
		} 
		x=m/2;
		for(i=1;i<=x;i++)
		{
			s.clear();
			finds(i,m-i,n);
		} 
		
		
		
		
		printf("%d\n",maxx);
	}
	
}



發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章