POJ 1111----F - 廣搜 基礎

                     
F - 廣搜 基礎
Time Limit:1000MS     Memory Limit:10000KB     64bit IO Format:%I64d & %I64u

Description

Technicians in a pathology lab analyze digitized images of slides. Objects on a slide are selected for analysis by a mouse click on the object. The perimeter of the boundary of an object is one useful measure. Your task is to determine this perimeter for selected objects. 

The digitized slides will be represented by a rectangular grid of periods, '.', indicating empty space, and the capital letter 'X', indicating part of an object. Simple examples are 
XX   Grid 1       .XXX   Grid 2 
XX                .XXX 
                  .XXX 
                  ...X 
                  ..X. 

 X... 

An X in a grid square indicates that the entire grid square, including its boundaries, lies in some object. The X in the center of the grid below is adjacent to the X in any of the 8 positions around it. The grid squares for any two adjacent X's overlap on an edge or corner, so they are connected. 
XXX 
XXX    Central X and adjacent X's 
XXX 

An object consists of the grid squares of all X's that can be linked to one another through a sequence of adjacent X's. In Grid 1, the whole grid is filled by one object. In Grid 2 there are two objects. One object contains only the lower left grid square. The remaining X's belong to the other object. 

The technician will always click on an X, selecting the object containing that X. The coordinates of the click are recorded. Rows and columns are numbered starting from 1 in the upper left hand corner. The technician could select the object in Grid 1 by clicking on row 2 and column 2. The larger object in Grid 2 could be selected by clicking on row 2, column 3. The click could not be on row 4, column 3. 

One useful statistic is the perimeter of the object. Assume each X corresponds to a square one unit on each side. Hence the object in Grid 1 has perimeter 8 (2 on each of four sides). The perimeter for the larger object in Grid 2 is illustrated in the figure at the left. The length is 18. 

Objects will not contain any totally enclosed holes, so the leftmost grid patterns shown below could NOT appear. The variations on the right could appear: 
Impossible   Possible 

XXXX         XXXX   XXXX   XXXX 
X..X         XXXX   X...   X... 

XX.X         XXXX   XX.X   XX.X 
XXXX         XXXX   XXXX   XX.X 

.....        .....  .....  ..... 

..X..        ..X..  ..X..  ..X.. 

.X.X.        .XXX.  .X...  ..... 

..X..        ..X..  ..X..  ..X.. 

.....        .....  .....  ..... 

Input

The input will contain one or more grids. Each grid is preceded by a line containing the number of rows and columns in the grid and the row and column of the mouse click. All numbers are in the range 1-20. The rows of the grid follow, starting on the next line, consisting of '.' and 'X' characters. 

The end of the input is indicated by a line containing four zeros. The numbers on any one line are separated by blanks. The grid rows contain no blanks. 

Output

For each grid in the input, the output contains a single line with the perimeter of the specified object.

Sample Input

2 2 2 2
XX
XX
6 4 2 3
.XXX
.XXX
.XXX
...X
..X.
X...
5 6 1 3
.XXXX.
X....X
..XX.X
.X...X
..XXX.
7 7 2 6
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
7 7 4 4
XXXXXXX
XX...XX
X..X..X
X..X...
X..X..X
X.....X
XXXXXXX
0 0 0 0

Sample Output

8
18
40
48
8

//@author:  yzj   Date:2015/07/26
//sourse :  http://acm.hust.edu.cn/vjudge/contest/view.action?cid=82603#problem/F
//meaning:  類似找油田,然後判斷周長
#include <iostream>
#include <cstdio>
#include <queue>

using namespace std;
const int  MAXN  = 22;
int n, m;
int sx, sy;
bool vis[MAXN][MAXN];
int step[MAXN][MAXN];
char c[MAXN][MAXN];
int ddx[9]={0,1,1,1, 0,-1,-1,-1,0};
int ddy[9]={1,1,0,-1, -1,-1,0,1,0};
int dx[4] = {0, 1, 0, -1};
int dy[4] = {1, 0, -1, 0};
int ans  = 0;

typedef pair<int, int> P;

//函數聲明
int cal_perimeter(int x, int y);

void bfs()
{
    queue<P> que;
    while(!que.empty())
    {
        que.pop();
    }
    for(int i = 0; i < MAXN; i++)
    {
        for(int j = 0; j < MAXN; j++)
        {
            vis[i][j] = false;
            step[i][j] = 0;
        }
    }
    que.push(P(sx, sy));
    vis[sx][sy] = true;
    step[sy][sy] = 0;
    if(sx==0)ans++;
    if(sx==n-1) ans++;
    if(sy==0)ans++;
    if(sy == m-1) ans++;
    while(! que.empty())
    {
        P p = que.front();
        //if(p.first == ex && p.second == ey) break;//return step[p.first][p.second];
        que.pop();
//        for(int i = 0; i < 8; i++)
//        {
        for(int i= -1; i <= 1; i++)
        {
            for(int j = -1; j <= 1; j++)
            {
                int nx = p.first + i, ny = p.second + j;
                if(0<=nx&&nx<n&&0<=ny&&ny<m&&!vis[nx][ny]&&c[nx][ny]=='X')
                {
                    if(nx==0)ans++;
                    if(nx==n-1) ans++;
                    if(ny==0)ans++;
                    if(ny == m-1) ans++;
                    ans+=cal_perimeter(nx, ny);
                    //cout << nx << "_" << ny << "-->" << cal_perimeter(nx, ny)<< "_" << ans << endl;
                    que.push(P(nx, ny));
                    vis[nx][ny] = true;
                    step[nx][ny] = step[p.first][p.second] + 1;
                }
            }
        }
//
//        }
    }
    //cout << "y" << ans << endl;
}

int cal_perimeter(int x, int y)
{
//    int tot =  0;
//    for(int i = 0; i < 4; i++)
//    {
//        int nx = x+dx[i], ny = y+dy[i];
//        if(c[nx][ny]=='X')
//        {
//            tot++;
//        }
//    }
//    if(tot == 0) return 4;
//    else if(tot == 1) return 3;
//    else if(tot == 2) return 2;
//    else if(tot == 3) return 1;
//    else return 0;
    int tot =  0;
    for(int i = 0; i < 4; i++)
    {
        int nx = x+dx[i], ny = y+dy[i];
        //這裏沒判斷是否越界,導致查了兩個小時的錯啊!
        if(! (0<=nx&&nx<n&&0<=ny&&ny<m)) continue;
        if(c[nx][ny]=='.')
        {
            tot++;
        }
    }
    return tot;
}

int main()
{
    //freopen("f:/yzj/cppCode/input.txt", "r", stdin);
    while(~scanf("%d %d %d %d", &n, &m, &sx, &sy))
    {
        if(n==0&&m==0&&sx==0&&sy==0)break;
        getchar();
        for(int i = 0; i < n; i++)
        {
            for(int j = 0; j < m;  j++)
            {
                scanf("%c", &c[i][j]);
            }
            getchar();
        }
//        for(int i = 0; i < n; i++)
//        {
//            for(int j = 0; j < m;  j++)
//            {
//               cout << c[i][j];
//            }
//            cout << endl;
//        }
//        cout<<endl;
        sx-=1;sy-=1;
        ans = 0;
        bfs();
        cout << cal_perimeter(sx, sy) + ans << endl;
    }
    return 0;
}


發表評論
所有評論
還沒有人評論,想成為第一個評論的人麼? 請在上方評論欄輸入並且點擊發布.
相關文章